FIX: 0xffffff7 Unspecified Error – Setup failed

Any issues, problems or troubleshooting topics related to installing the Prepar3D client application or it's installer.
uncertifiedpilot
Posts: 3
Joined: Wed Dec 17, 2014 4:31 pm

Postby uncertifiedpilot » Thu Dec 18, 2014 1:29 pm

Issue: “0xffffff7 Unspecified Error – Setup failed” message halfway through the Prepar3D installation

Likely cause: Fresh windows 7 install (with SP1 and all updates) does not include older DirectX components that are required to complete the Prepar3D installation and run Prepar3D.

Solution summary: disable your anti-virus software (obstructs the installation apparently), run the dxwebsetup.exe (see link below) as an Administrator to install older DirectX 9 + 10 files that are needed to run Prepar3D. Then, install and run Prepar3D in Administrator mode.

My actual actions taken:

> After prompted with the installation error:

1) Browsed to C:\ProgramData\Package Cache\ and deleted everything in that folder

2) Ran the setup.exe again. Got prompted with the same error.

3) Browsed to C:\ProgramData\Package Cache\ and executed all the packages contained in each subfolder, doing the Prepar3D.msi LAST. In this way, you will do the job of the installer manually.

4) Then, executed the Prepar3D.msi. This time, the installation did continue and completed. After completion I got prompted with a DirectX9 error.

5) Got to http://www.microsoft.com/en-us/download/details.aspx?id=35 and downloaded the dxwebsetup.exe. Ran it, got an error that the installation could not be completed. Read that anti-virus programs might prevent the installation to complete (some recommended to reboot in safe mode, but this didn't do me any good). I also read that you need to run the dxwebsetup.exe in Administrator mode. So, disabled my anti-virus program and executed the dxwebsetup.exe in Administrator mode (right-click and select 'Run as Administrator'). Worked.

6) After the dxwebsetup.exe was completed, started up Prepar3D but got the error that Prepar3D couldn't be started because it needed Administrator mode too. Re-started Prepar3D in Administrator mode and ... mission success.

HaydenWalkerACpilot
Posts: 1
Joined: Sat May 02, 2015 4:49 am

Postby HaydenWalkerACpilot » Sat May 02, 2015 10:40 am

Can I ask how you ran them?? I'm having the exact same issue..


Return to “Prepar3D Installation and Installer Questions”

Who is online

Users browsing this forum: No registered users and 2 guests