Graphics suddenly producing blocks

Any issues, problems or troubleshooting topics related to the Prepar3D client application.
howesa
Posts: 4
Joined: Sat Jan 12, 2019 4:24 pm

Graphics suddenly producing blocks

Postby howesa » Sat Jan 12, 2019 4:39 pm

New instalation of Prepar2d v 4, A2A Piper aircraft add on, ORBX scenery, Spad.next for controllers, all working just fine...
For unknown reason, P3d starts all fine but scenery has lost most of its detail, e.g. walking figures are grey 'blobs,' clouds are series of overlaid rectangles and so on.
Not a graphics card problem as FSX all runs fine on same machine.
I have verified ORBX scenery files, and re run autoconfig for Vector, all ok.
I would attach screen shot but cannot see how to do this so far.

Tried to run a repair from the P3d installer but this got right to the end and gave an two error messages:

1) A file that is required cannot be installed because the cabinet file has invalid signature
File is scene3.cab in C:\ProgramData\Package Cache\....<big long number>...v4.4.16.27077
2) One or more issues caused the setup to fail, 0x80070643 - Fatal error during installation.

Any ideas as it is unusable in it's present state!

Many thanks

howesa
Posts: 4
Joined: Sat Jan 12, 2019 4:24 pm

Re: Graphics suddenly producing blocks

Postby howesa » Sat Jan 12, 2019 5:12 pm

Have just run the repair option from P3d and it ran to the end just fine this time...BUT graphics still not fixed unfortuneatley..

howesa
Posts: 4
Joined: Sat Jan 12, 2019 4:24 pm

Re: Graphics suddenly producing blocks

Postby howesa » Sat Jan 12, 2019 5:42 pm

Just read how to get image to you...
Image
Hope that works and is helpful

User avatar
Rob McCarthy
Lockheed Martin
Posts: 2206
Joined: Wed Aug 24, 2011 1:37 pm

Re: Graphics suddenly producing blocks

Postby Rob McCarthy » Mon Jan 14, 2019 3:48 pm

Hello,

Are you seeing this on a clean installation? Are you graphics drivers up to date?
Our general debugging steps located here may also help track down the source of the issue:
https://www.prepar3d.com/forum/viewtopi ... 2&t=123246

Regards,
Rob McCarthy
Rob McCarthy
Prepar3D® Core Lead

howesa
Posts: 4
Joined: Sat Jan 12, 2019 4:24 pm

Re: Graphics suddenly producing blocks

Postby howesa » Mon Jan 14, 2019 5:41 pm

Rob, many thanks for getting back to me.

Graphics drivers are fine, and all was fine until I started removing some unwanted button associations within Prepa3d and tweaking Spad.Next.
FSX was still running fine but whilst new to Prepar3d, I was missing it already!
Anyway, over the weekend I did some research and one suggestion was to run the delete generated files shortcut in the main installation folder which deleted the local, roaming and program data content.
That removed all my settings of course, I also uninstalled all ORBX scenery as well.
That sorted it. I re downloaded ORBX, bit of a long process on our 3mb broadband, but got there.
That fixed it, only for it to happen all over again...some very rude words!
Second time around I deleted the files again, left ORBX in place this time, and I am back working again, for now.
So if it says stable I will clone my hard disc, which I do at sensible intervals anyway.
Meantime I have made copies of the generated file directory content as a back up to copy back in if it goes wrong again, if that would work?
Somehow corruption is sneaking in, but why, I have no idea.

Any thoughts appreciated Rob

Many thanks


Return to “Prepar3D Client Application Questions”

Who is online

Users browsing this forum: No registered users and 16 guests