DXGI Device Hung error

Any issues, problems or troubleshooting topics related to computer hardware and the Prepar3D client application
navaneethgireesh
Posts: 1
Joined: Sat Jul 18, 2020 7:14 pm

DXGI Device Hung error

Postby navaneethgireesh » Sat Jul 18, 2020 7:24 pm

Hello, I have installed P3D V5 only a few days, it looks really great but I have been getting this error (DXGI Device Hung....) countless times, especially when I am almost about to land!

My system specs are below:

Processor: i7-8700k (not overclocked)
RAM: 16 gb
GPU: AMD RX5700XT
Windows 10 64 Bit version 2004

The main addons I have are: Activesky and chaseplane and I usually fly the PMDG 777 and the FSLabs 320, I get the error when I fly both these aircraft?
Is there any way to debug/solve this at all? I was assuming HF2 would fix these issues but maybe its a problem isolated to my setup?

User avatar
Martyson
Posts: 9975
Joined: Sun Mar 25, 2012 11:08 am

Re: DXGI Device Hung error

Postby Martyson » Sat Jul 18, 2020 7:29 pm

Hello, I have installed P3D V5 only a few days, it looks really great but I have been getting this error (DXGI Device Hung....) countless times, especially when I am almost about to land!

My system specs are below:

Processor: i7-8700k (not overclocked)
RAM: 16 gb
GPU: AMD RX5700XT
Windows 10 64 Bit version 2004

The main addons I have are: Activesky and chaseplane and I usually fly the PMDG 777 and the FSLabs 320, I get the error when I fly both these aircraft?
Is there any way to debug/solve this at all? I was assuming HF2 would fix these issues but maybe its a problem isolated to my setup?
PMDG777 is not supported for P3Dv5.

Have you tested with a default LM P3Dv5HF2 aircraft / scenery / flight without using Add-ons?
Best Regards,
Vaughan Martell (KDTW)


Return to “Hardware Specific Questions”

Who is online

Users browsing this forum: Google [Bot] and 23 guests