RTX 2080 Ti stopped working

Any issues, problems or troubleshooting topics related to computer hardware and the Prepar3D client application
MPatrickW
Posts: 4
Joined: Wed Nov 21, 2018 1:28 pm

RTX 2080 Ti stopped working

Postby MPatrickW » Sun May 24, 2020 10:12 am

P3D v5 with latest hotfix gives this error message with reason: UNKNOWN after the scenario screen. Fresh install, no additional scenery or aircraft, no addons at all, completely vanilla. My card is an MSI RTX 2080 Ti Gaming X Trio with 11mb VRAM with full DirectX12 capability. Latest video drivers and Win 10 version. High spec hardware with i7 9700k and 32GB ram. I can’t be the only one, so please LM, can you advise a solution, or if you are aware it is a widespread problem, when will this be fixed?

JorgenSA
Posts: 2467
Joined: Sun Mar 11, 2018 7:17 am
Location: 5 NM NE of EDXF

Re: RTX 2080 Ti stopped working

Postby JorgenSA » Sun May 24, 2020 10:35 am

If you had searched and read the threads, you would have seen:

1. That it is indeed a widespread problem, and not confined to RTX 2080 cards, and

2. That it is an acknowledged problem, but possibly not confined to P3D, could be a DX12 or driver issue also, and

3. That L-M has acknowledged the problem, and

4. That L-M is working on their side of it.

So, any solutions in sight? From here on it is my speculation, but yes, Windows 10 version 2004 is supposed to be released to the general public next week, supposedly containing DX12 fixes, plus the latest nVidia drivers came out on April 15, so new drivers are highly over due but probably waiting for the new Windows 2004 update.

Sometime after that, a new Hotfix for P3D might just be coming out.

Jorgen
Thread-reader, not an L-M employee.

PS: A lot of caveats here....
System: i7-7700K @ 4.66 GHz, ASUS Z170-A motherboard, 16 GB 3200 MHz DDR4 RAM, nVidia GTX 960 w/ 4 GB DDR5 VRAM, Windows 10 Home.

All views and opinions expressed here are entirely my own. I am not a Lockheed-Martin employee.

MPatrickW
Posts: 4
Joined: Wed Nov 21, 2018 1:28 pm

Re: RTX 2080 Ti stopped working

Postby MPatrickW » Sun May 24, 2020 10:42 am

Jorgen, thank—you for taking the trouble to summarise with clarity and more then I did get from reading all other posts. Much appreciated.

JorgenSA
Posts: 2467
Joined: Sun Mar 11, 2018 7:17 am
Location: 5 NM NE of EDXF

Re: RTX 2080 Ti stopped working

Postby JorgenSA » Sun May 24, 2020 11:15 am

I have read that the supposed release time for the 2004 update is going to be the 28th, so we'll see what happens.

Jorgen
System: i7-7700K @ 4.66 GHz, ASUS Z170-A motherboard, 16 GB 3200 MHz DDR4 RAM, nVidia GTX 960 w/ 4 GB DDR5 VRAM, Windows 10 Home.

All views and opinions expressed here are entirely my own. I am not a Lockheed-Martin employee.

Martyson
Posts: 9620
Joined: Sun Mar 25, 2012 11:08 am

Re: RTX 2080 Ti stopped working

Postby Martyson » Sun May 24, 2020 1:45 pm

P3D v5 with latest hotfix gives this error message with reason: UNKNOWN after the scenario screen. Fresh install, no additional scenery or aircraft, no addons at all, completely vanilla. My card is an MSI RTX 2080 Ti Gaming X Trio with 11mb VRAM with full DirectX12 capability. Latest video drivers and Win 10 version. High spec hardware with i7 9700k and 32GB ram. I can’t be the only one, so please LM, can you advise a solution, or if you are aware it is a widespread problem, when will this be fixed?
I use RTX 2080 Ti 11GB and no problems to report.

Do you have a home built PC or a store name brand?
Best Regards,
Vaughan Martell (KDTW)

MPatrickW
Posts: 4
Joined: Wed Nov 21, 2018 1:28 pm

Re: RTX 2080 Ti stopped working

Postby MPatrickW » Fri May 29, 2020 7:12 pm

I built my PC. Motherboard is MSI Meg z390 Ace. All been fine for the two years I’ve had it. No recent changes or hardware additions. This is the first time I’ve had a CTD from anything. P3D v4.5 is fine, but I can’t even get to the scenario screen before it bombs.


Return to “Hardware Specific Questions”

Who is online

Users browsing this forum: No registered users and 46 guests