New Titan RTX - P3D display now worse than before?

Any issues, problems or troubleshooting topics related to computer hardware and the Prepar3D client application
User avatar
andy1252
Posts: 33
Joined: Fri Dec 19, 2014 4:16 pm

New Titan RTX - P3D display now worse than before?

Postby andy1252 » Fri May 10, 2019 3:03 pm

OK, a bit OTT but I've just bought and installed a Titan RTX to replace a 980Ti. My thinking was primarily VRAM size related with regard to XP11 (and it already has confirmed my feelings there, some of my scenarios there showing over 13gb VRAM use).

BUT - I'm getting all sorts of problems with P3D (4.4). I've done the DDU thing as recommended, and although I can see figures like <50% CPU (4790 @4.6ghz and 32gb ram), and the Titan is showing maybe 30% GPU and never more than 8gb VRAM usage, my frame rates are appalling (5-15 if there's any kind of complex scenery) and I'm getting lots of pauses and blurred scenery.

So my questions are - is anyone aware of any issues with the Titan and/or the latest NV drivers, and is there anything really obvious and stoopid I may have overlooked. My graphics settings are set mostly to max or just one below, and I used to be able to do that with the 980. May not have gotten decent frame rates a lot of the time but a lot less of the blurries.

Scenery involved is mostly ORBX (I have all their stuff) plus loads of other heavy hitters like DD etc. And like I say, and this is not any kind of criticism of P3D, I've not had any problems with the XP or AFS2 side of things since the change of GPU. It's only with the P3D system so I assume I've missed something somewhere.

Don't really want to do a re-install but then again it might be time to make a fresh start with 4.5 and maybe not reinstall some of those little joys that turn out not so wonderful anyway. I'm assuming I should get some pretty impressive results from P3D and ORBX with a Titan!

ppo
Posts: 79
Joined: Mon Nov 25, 2013 3:52 pm

Re: New Titan RTX - P3D display now worse than before?

Postby ppo » Fri May 10, 2019 3:55 pm

Video driver used ??
Also, a change in video card requires a clean up of the shaders

User avatar
andy1252
Posts: 33
Joined: Fri Dec 19, 2014 4:16 pm

Re: New Titan RTX - P3D display now worse than before?

Postby andy1252 » Fri May 10, 2019 4:00 pm

Driver is the recommended from the NV site (430.39) and yep, cleared the shaders.

User avatar
MikeB54
Posts: 276
Joined: Sat Nov 22, 2014 11:46 pm
Location: Hudson, NH

Re: New Titan RTX - P3D display now worse than before?

Postby MikeB54 » Fri May 10, 2019 7:44 pm

There is a hotfix out for that driver. I don't know if it will fix your issue, but you can check it out here: https://nvidia.custhelp.com/app/answers ... /a_id/4798


Mike

User avatar
andy1252
Posts: 33
Joined: Fri Dec 19, 2014 4:16 pm

Re: New Titan RTX - P3D display now worse than before?

Postby andy1252 » Fri May 10, 2019 7:59 pm

Thanks for that, Mike. I'm not terribly up on Nvidia drivers generally - I don't think I've ever updated the drivers for the 980 since I got it a few years back. With drivers generally I tend to go for the "ain't broke, don't fix it" approach. I've gone off to get this though and I'll see how it goes. I have actually also just gotten going on a clean 4.5 install anyway, but I'll see how I feel about following through on that. I've got a huge amount of stuff to re-install and I may yet end up backing out to the 4.4 system if it starts to get painful.

Thanks again, and I'll report back here how it all goes.

User avatar
andy1252
Posts: 33
Joined: Fri Dec 19, 2014 4:16 pm

Re: New Titan RTX - P3D display now worse than before?

Postby andy1252 » Sat May 11, 2019 2:31 pm

Just to update anybody who might be looking at this.

I've installed the Nvidia hotfix, and it hasn't made any noticeable difference. Still getting mostly lousy frame rates and lots of stutters unless I lower my settings way down. I have gone for a clean install of 4.5, and at least I'm not getting the 6% load delay now (for all the good that does me), but I'm a long way off sorted.

I guess I'll keep on experimenting and wait for the upcoming 4.5 patch. I've got way too much invested in P3D to abandon it completely but it's beginning to feel like a dead end unless something major happens with the central core of the engine. My Titan is doing exactly what I hope of it with XP but you'd never believe it was there in P3D.

User avatar
andy1252
Posts: 33
Joined: Fri Dec 19, 2014 4:16 pm

Re: New Titan RTX - P3D display now worse than before?

Postby andy1252 » Mon May 13, 2019 4:07 pm

Latest news - set a CPU affinity mask of "84" (on a 4790k) and getting some more reasonable frame rates now. VSynced, 30fps, and beginning to see some progress. Certainly didn't have to do any of this before though.

User avatar
andy1252
Posts: 33
Joined: Fri Dec 19, 2014 4:16 pm

Re: New Titan RTX - P3D display now worse than before?

Postby andy1252 » Wed May 15, 2019 7:38 pm

OK, so I've got the hotfix installed (client and content) and it's not perfect yet, but it is a whole lot better than it was. I guess I'm just going to have to accept a couple of things. One is that I will need to tweak to get the best out of my system - I guess the extra headroom in the graphics card is putting more focus on the CPU performance now for some reason. And the second thing is that P3D is just not going to give me the same sort of performance as XPlane. Not bitching, just accepting.


Return to “Hardware Specific Questions”

Who is online

Users browsing this forum: No registered users and 7 guests