P3Dv4.2 VR Single Pass Rendering Mode Issue

For all topics that don't fit into another category. Note that we cannot promise that any of these posts will be responded to by our development team.
powayjoe
Posts: 48
Joined: Tue Oct 08, 2013 9:49 pm

Re: P3Dv4.2 VR Single Pass Rendering Mode Issue

Postby powayjoe » Sat Feb 17, 2018 4:23 pm

I get the exact same roof artifacts as well as the ship artifacts shown earlier.

I was testing with all traffic, autos, boats etc. turned off as well as no autogen and Orbx uninstalled and shader files deleted to rebuild and still they were present.

Again when I would toggle between Single Pass Rendering and Stereo modes they would come and go as I toggle back and forth.

Thanks for the continued support
Joe
I5-2500K 4.5Ghz, GTX-1070 OC, Corsair Vengeance 2133Mhz, SSD, Oculus Rift, 40 inch 4K Screen at 30 Hz, VKB Gunfighter, Virpil Moongoost 50,MFG Crosswind Pedals, ChasePlane, Linda, VoiceAttack, FFTF, Pilot2ATC apps

Simpilot1
Posts: 8
Joined: Mon Feb 23, 2015 5:30 pm

Re: P3Dv4.2 VR Single Pass Rendering Mode Issue

Postby Simpilot1 » Sun Feb 18, 2018 12:14 am

Hi Folks,
I experience a 100% CTD when using Single Pass Rendering mode.
Affected moodule: g2d.dll in any case.

Name der fehlerhaften Anwendung: Prepar3D.exe, Version: 4.2.21.24048, Zeitstempel: 0x5a7c832c
Name des fehlerhaften Moduls: g2d.dll, Version: 4.2.21.24048, Zeitstempel: 0x5a7c83fb
Ausnahmecode: 0xc0000005
Fehleroffset: 0x000000000011a2a6
ID des fehlerhaften Prozesses: 0x2124
Startzeit der fehlerhaften Anwendung: 0x01d3a81f35ac83ad
Pfad der fehlerhaften Anwendung: C:\Program Files\Lockheed Martin\Prepar3D v4\Prepar3D.exe
Pfad des fehlerhaften Moduls: C:\Program Files\Lockheed Martin\Prepar3D v4\g2d.dll
Berichtskennung: 5cd9e1a6-164e-4cbc-8c01-187ad9c9f333
Vollständiger Name des fehlerhaften Pakets:
Anwendungs-ID, die relativ zum fehlerhaften Paket ist:
I can repeat this example.

After some heavy influence on the sim (reinstall, client, content and scenery) and even on Oculus software (I need to reinstall because glasses stay black) I have now the chance to fly around 15-20 minutes within SPR mode but than again CTD.I tried the other modes with same setup and no issue at all.
Geforce Driver is 390.77, FSUIPC 5.121b; ActivySky (updated), Orbx NA,EU, BAse,Vector, trees (fastlane update), Rex4 texture direct and soft Clouds, Scenarios flown with PMDG777.

SPR mode is great improvement in performance but no option with continuing CTD.
Any thoughts?
Thanks in advance.
Andreas Hövel

Britjet1
Posts: 24
Joined: Thu Jan 16, 2014 1:07 pm

Re: P3Dv4.2 VR Single Pass Rendering Mode Issue

Postby Britjet1 » Sun Feb 18, 2018 10:16 am

Just FYI, I have these artifacts as well. They are large and occur every few seconds. I am using GTX 1080Ti and 6700 processor with 32Gb RAM.
They occur even at the lowest graphics settings, and in default areas.
Apart from that, Single-pass is great!

Britjet.

kdfw
Posts: 18
Joined: Tue Jun 27, 2017 3:33 am

Re: P3Dv4.2 VR Single Pass Rendering Mode Issue

Postby kdfw » Mon Feb 19, 2018 6:33 am

general question regarding the single pass rendering: is this feature based on nvidia's gfx card driver api? is this something nvidia is actively supporting and can offer a fix via driver update?

User avatar
Kayla Kinzel
Lockheed Martin
Posts: 1267
Joined: Mon Aug 01, 2016 5:59 pm

Re: P3Dv4.2 VR Single Pass Rendering Mode Issue

Postby Kayla Kinzel » Mon Feb 19, 2018 11:28 am

Hello all,

As stated above, with default Prepar3D, we are unable to reproduce the issue exactly as you guys explain it. In a post above, I attached a picture of what we are able to replicate.

Can you please provide detail repro steps, without any addons installed, to help us see this issue?

Thanks for your time,
Kayla
Prepar3D® Software Engineer

Britjet1
Posts: 24
Joined: Thu Jan 16, 2014 1:07 pm

Re: P3Dv4.2 VR Single Pass Rendering Mode Issue

Postby Britjet1 » Mon Feb 19, 2018 12:33 pm

Hi Kayla,

I have done some further investigation and the issue seems to be limited to add-on airport scenery, but not including default, as I said earlier. Sorry...
I have the issue with the majority of my recent add-ons which are mainly V4-specific.
Some airports seem worse than others, but the flashing artifacts are part of the add-on scenery, for example with Drzewiecki Seattle I get (among other things) flashes of an aircraft carrier deck. With Aerosoft Barcelona I get dock containers. Aerosoft Frankfurt is particularly bad with, among other things, huge red stripes emanating from a distant point.
I have tried switching on and off literally every option I can find in the Prepar3D UI without success, except for switching off single-pass, which fixes it. I have tried different versions of FSUIPC as well.
I am using the latest NVIDIA driver 390.77.
I forced a rebuild of Prepar3D.cfg as well. I have no performance tweaks, but am using PTA shaders.
Thanks for looking into this..
Britjet

powayjoe
Posts: 48
Joined: Tue Oct 08, 2013 9:49 pm

Re: P3Dv4.2 VR Single Pass Rendering Mode Issue

Postby powayjoe » Mon Feb 19, 2018 3:20 pm

I reimaged my disk back to before the v4.2 install but will be trying again soon.

I tried many of the above mentioned techniques to remedy the issue as well and nothing worked.
I did uninstall my Orbx KSAN airport and the issue of ships flashing in the terminal did not change. Also I tried Lagurdia and Heathro airports where I have no addon airports and they had flashing artifacts as well.

Are you sure you get no artifacts at P3D airports that haven’t been changed with addons?

Thanks in advance
Joe
I5-2500K 4.5Ghz, GTX-1070 OC, Corsair Vengeance 2133Mhz, SSD, Oculus Rift, 40 inch 4K Screen at 30 Hz, VKB Gunfighter, Virpil Moongoost 50,MFG Crosswind Pedals, ChasePlane, Linda, VoiceAttack, FFTF, Pilot2ATC apps

cannow
Posts: 75
Joined: Mon Nov 25, 2013 5:51 pm

Re: P3Dv4.2 VR Single Pass Rendering Mode Issue

Postby cannow » Mon Feb 19, 2018 4:26 pm

I thought I had disabled everything when I posted pictures took at EGKK . Maybe there was something still hidden in world scenary . Only way will be a full re-install then add scenary one at a time until I trigger the fault. I don't think the issue is with one individual add on . I need to find time to do this but is a major endeavour .

KUB10
Posts: 25
Joined: Sun Jun 02, 2013 5:56 pm

Re: P3Dv4.2 VR Single Pass Rendering Mode Issue

Postby KUB10 » Thu Feb 22, 2018 9:59 am

Same problem here and I did some testing. First started vanilla P3d at PANC and all was normal. Added ORBX Global, all normal. Added ORBX LC North America artefacts appeared. Added airports LFPG Taxi2Gate and Flytampa CYYZ, got artefacts. When I turning down scenery complexity to very sparse all is normal, as soon I increase to sparse its coming back at CYYZ but very few. From above sparse its goeing crazy, but LFPG is not that affected than CYYZ. AI aircrafts are affected too, using Ultimate Traffic Live.

When using normal stereo everything is back to normal.

Sven

Simpilot1
Posts: 8
Joined: Mon Feb 23, 2015 5:30 pm

Re: P3Dv4.2 VR Single Pass Rendering Mode Issue

Postby Simpilot1 » Thu Feb 22, 2018 4:55 pm

As stated earlier I have the same issue.
But again when seeing artifacts some seconds later P3D ctd with no exception.
When staring up at EDDL no Scenery add-on pure default I get the artifacts.
I also suppose ORBX as possible rootcause. And it can be only the packages
that cover regions. In my case it is LC NA and LC Europe. When I start in Asia
or default flight F22 at Edwards I can go with SPR.
Stereo even works fine.

I would like to try clean install with all the efforts, but as Long it is not clear if Nvidia Driver 390.77
can cause issue with SPR as stated in some threads and with Oculus I'm intended to avoid this.

Any thoughts?
BR
Andreas

powayjoe
Posts: 48
Joined: Tue Oct 08, 2013 9:49 pm

Re: P3Dv4.2 VR Single Pass Rendering Mode Issue

Postby powayjoe » Fri Feb 23, 2018 3:59 am

After I uninstalled and reinstalled 4.2 client I have the same issue as before. One thing I can say now is that the large beam looking artifacts that appear above the aircraft canopy are actually emanating from the airport buildings. It is as though the structures are stretching out in a distorted perspective toward my viewpoint in the aircraft. I only see these artifacts at addon airports like Orbx KSAN or Flightbeam KSFO. I do however still see several roof tops, not the house just the rooftop, appear all over the airports that aren’t addons like La Guardia. Again only in SPR mode.

Joe
I5-2500K 4.5Ghz, GTX-1070 OC, Corsair Vengeance 2133Mhz, SSD, Oculus Rift, 40 inch 4K Screen at 30 Hz, VKB Gunfighter, Virpil Moongoost 50,MFG Crosswind Pedals, ChasePlane, Linda, VoiceAttack, FFTF, Pilot2ATC apps

cannow
Posts: 75
Joined: Mon Nov 25, 2013 5:51 pm

Re: P3Dv4.2 VR Single Pass Rendering Mode Issue

Postby cannow » Fri Feb 23, 2018 5:54 pm

As LM seem to have no idea and we are not going to get help from developers. Had a post in orbx forum for a week no answer . No idea where to go now with this . LM might as well right off mode as no good . Really hope this can be fixed as single potentially is great . Please LM respond.

Simpilot1
Posts: 8
Joined: Mon Feb 23, 2015 5:30 pm

Re: P3Dv4.2 VR Single Pass Rendering Mode Issue

Postby Simpilot1 » Fri Feb 23, 2018 10:34 pm

I believe that add-on airports are not the rootcause as I have this issue still at a default one.
I suppose area add-ons will be the reason and I also think only uninstall this will not bring the
result we want.
I'm thinking about to completely vanish P3D from the system and install from scratch as recommended by LM.
As I see VR is the most awaited development of flightsimming since years I will invest this time to find out.
If the Nvidia Driver causes this issue I should see issue with clean install.
KR
Andreas

cannow
Posts: 75
Joined: Mon Nov 25, 2013 5:51 pm

Re: P3Dv4.2 VR Single Pass Rendering Mode Issue

Postby cannow » Sat Feb 24, 2018 1:08 pm

LM can you have another look at this issue . Pictures took with a clean install of P3D all folders wiped no add ons at all .Default settings for my install . They were took at Gate 107 EGKK Gatwick with a A36 traffic was on . This should be reproducible your end. I have an occulus rift and 1070 card latest graphics card 390.77 and latest rift 2.0 software . traffic was on .No weather . Please have another look now to spend hours re-installing the rest of my system .
Over to you now

https://www.amazon.co.uk/clouddrive/sha ... XNxi2uV3ij
https://www.amazon.co.uk/clouddrive/sha ... 2Unxxm2ojM

powayjoe
Posts: 48
Joined: Tue Oct 08, 2013 9:49 pm

Re: P3Dv4.2 VR Single Pass Rendering Mode Issue

Postby powayjoe » Sat Feb 24, 2018 3:33 pm

These are the exact same artifacts I have been seeing no matter what I do as well.
It appears the airport structures are stretching out in a distorted manner but that is clearly different than the random roof tops that appear in airports at various locations all over the world for me.

Thanks for all your efforts and I agree it’s up to LM now.

As an aside I use FlyInside because of the ability to zoom, bring up and interact with pop ups like PMDG CDU and GTN 750 as well as exterior windows like Little Navmap. I know P3Dv4.2 keeps a config log of the VR mode we last fly, I have checked and it assigns either a 1, 2 or3 so when it launches the next time it remembers if we prefer mono, SPR or Stereo. Since FlyInside doesn’t change this entry I assume it launches P3D with SPR on if that’s what I last used.

Ironically I don’t get any of these artifacts when I use FlyInside and it looks to me the frame rates are better now in FI making me think it’s using SPR so why no artifacts in all the same places I get them with P3Dv4.2 Native VR SPR?

Does FI revert the renedering mode back to Stereo and over write P3D, it doesn’t seem to and if it doesn’t why no artifacts?

If only LM could provide what FlyInside does, seems amazing to me they can’t!

Joe
I5-2500K 4.5Ghz, GTX-1070 OC, Corsair Vengeance 2133Mhz, SSD, Oculus Rift, 40 inch 4K Screen at 30 Hz, VKB Gunfighter, Virpil Moongoost 50,MFG Crosswind Pedals, ChasePlane, Linda, VoiceAttack, FFTF, Pilot2ATC apps


Return to “Miscellaneous”

Who is online

Users browsing this forum: No registered users and 9 guests