Models flickering in Targeting Pod Camera - UPDATE

Any issues, problems or troubleshooting topics related to the additional features present in the Prepar3D Professional Plus client application.
tauseefAhmed
Posts: 38
Joined: Wed Jul 31, 2019 4:56 pm

Models flickering in Targeting Pod Camera - UPDATE

Postby tauseefAhmed » Wed Mar 11, 2020 3:52 am

Hello!
For the past few days I've been trying to solve an issue regarding the P3D SimObjects rendering problem in TargetingPod Camera. The models have a strange tendency to flicker when we see them in Targeting Pod View Camera
I have posted the issue, along with a video sample, on the development forum but didn't get any response from over there. I've searched may forums but none of them have answers to this very problem I'm referring to.
Sadly I didn't get any response from the development forum.

Can anyone from LM please take a look at the issue and help me finding a solution?


Here's the link to the original post I'm referring to.

viewtopic.php?f=6309&t=136373

NOTES:
My PC Specs are as follows.

Alienware Area 51
CPU: Intel Core i7 6800K 3.4 GHz
RAM: 32 GB
GPU: Nvidia TitanX



Thank you for your time.

obinder
Posts: 144
Joined: Sun Jun 08, 2014 9:43 am

Re: Models flickering in Targeting Pod Camera - UPDATE

Postby obinder » Wed Mar 11, 2020 5:09 pm

Hi,

this is not limited to the targeting pod. The same flickering happens when you zoom in a camera to a very high level and something is moving (either you or the object that you are watchin). This is most notable on certain AI aircraft (for example the CH-53 is exceptionally bad), but I am also seeing it in trees and clouds. High zoom settings seem to cause problems with the Z-buffering.

I would assume that the targeting pod is also using a normal camera, with added post processing, at a very high zoom.

This is just something that P3D does. Not sure if it has always been there, but I think that this issue is relatively new.

Best regards
Oliver Binder
Lorby-SI

tauseefAhmed
Posts: 38
Joined: Wed Jul 31, 2019 4:56 pm

Re: Models flickering in Targeting Pod Camera - UPDATE

Postby tauseefAhmed » Fri Mar 13, 2020 5:45 am

Hello obinder,
Thank you for your reply.

Yeah, you're right. Same issue exists with other camera views as well. And it is not specific to SimObjects. Scenery objects are showing this behavior as well.
Have other people pointed out this issue? Shall we expect a fix from LM anytime soon? I'm currently using version 4.5

Any recommended settings to reduce the effect to a possible minimum value?
I would really appreciate if you could guide me to reduce this effect.

It becomes too weird to look at objects up close.

Thank you for your time.

obinder
Posts: 144
Joined: Sun Jun 08, 2014 9:43 am

Re: Models flickering in Targeting Pod Camera - UPDATE

Postby obinder » Sun Mar 15, 2020 7:57 pm


Any recommended settings to reduce the effect to a possible minimum value?
Hi,

To be honest, I haven't really looked into this. I just have the same effect in my own apps when zooming in too much on a moving simobject.

Normally I would try changing the clipmode of that camera, but since the targeting pod is a PDK created asset, I don't think that you can.

I'm not sure about the targeting pod, but I always get flickers when there are several docked views open in the sim at the same time. Undocking the additional views to separate windows sometimes stops the flickering.

Best regards
Oliver Binder
Lorby-SI

tauseefAhmed
Posts: 38
Joined: Wed Jul 31, 2019 4:56 pm

Re: Models flickering in Targeting Pod Camera - UPDATE

Postby tauseefAhmed » Mon Mar 16, 2020 5:33 am

Thank you very much.
Appreciate your help.


Still looking for someone from LM team to help me resolve this issue.

niksan29
Posts: 134
Joined: Wed Aug 12, 2015 4:14 pm
Location: USTR

Re: Models flickering in Targeting Pod Camera - UPDATE

Postby niksan29 » Wed Apr 29, 2020 10:05 pm

to help me resolve this issue.
Hi!
It doesn't look like this:
https://youtu.be/-UXq6TuSPNQ
https://www.prepar3d.com/forum/viewtopi ... 34#p214410 ?
Cheers!

tauseefAhmed
Posts: 38
Joined: Wed Jul 31, 2019 4:56 pm

Re: Models flickering in Targeting Pod Camera - UPDATE

Postby tauseefAhmed » Thu Apr 30, 2020 7:31 am

Yes, something like that. But it is more visible when I'm in TV mode than in IR modes and it is visible more on SimObjects i.e. Tanks, cars etc. Scenery objects, unlike your case, tend to show less flickering.

The whole texture flickers.
Did you watch the video I posted? Might help you to compare both these effects.

niksan29
Posts: 134
Joined: Wed Aug 12, 2015 4:14 pm
Location: USTR

Re: Models flickering in Targeting Pod Camera - UPDATE

Postby niksan29 » Thu Apr 30, 2020 2:52 pm

Yes, something similar and the problem is also related to camera mode...
It seems that there is a certain small group of users (including us) who are experiencing similar flickering problems, perhaps the LM will pay attention to this...
Cheers!

remcosol
Posts: 105
Joined: Tue Apr 03, 2012 5:31 pm

Re: Models flickering in Targeting Pod Camera - UPDATE

Postby remcosol » Fri May 01, 2020 3:14 pm

Hello!

The issue i am seeing is flickering of the clouds. When that happens the frame rate also drops from a steady 50 to 20-30 and stuttering occurs.

V5 runs very smoothly outside this issue . I have tried new drivers and all sorts of combinations of vert sync frame rate etc.

Never seen that in v4.

tauseefAhmed
Posts: 38
Joined: Wed Jul 31, 2019 4:56 pm

Re: Models flickering in Targeting Pod Camera - UPDATE

Postby tauseefAhmed » Mon May 04, 2020 5:09 am

Hello remcosol,

So are you suggesting that updating P3D to V5 would solve the flickering issue?


Return to “Prepar3D Professional Plus Client Application Questions”

Who is online

Users browsing this forum: No registered users and 20 guests