Missing Shaders Directory

Any issues, problems or troubleshooting topics related to installing the Prepar3D client application or it's installer.
Megdun
Posts: 3
Joined: Fri Apr 07, 2017 11:23 pm

Missing Shaders Directory

Postby Megdun » Fri Jun 26, 2020 8:50 am

Hi All

Out of the blue today I received the No Shader HLSL directory found. I found troubleshooting:

http://www.prepar3d.com/forum/viewtopic.php?t=120763

I did that and it did not resolve the issue. I did a complete uninstall and reinstall with a restart between to no avail.

I do note though that I received the Microsoft Edge update today. Could that have had something to do with it?

I'm running P3v4. any help would be greatly appreciated.

Thanks..

Matt

JorgenSA
Posts: 2732
Joined: Sun Mar 11, 2018 7:17 am
Location: 5 NM NE of EDXF

Re: Missing Shaders Directory

Postby JorgenSA » Fri Jun 26, 2020 9:05 am

After seeing these reports about the HLSL shaders folder suddenly gone, I decided to check this also on my system.

I upgraded to the latest nVidia driver on the 24th, and did not see any issue with the upgrade or after that.

So this morning (local time) I flew both v. 4.5 HF3 and v. 5 HF2 without seeing any errors at all.

Also, the number of reports we have in these forums of this issue is below a dozen.

The conclusion therefore is this:

1. This is not an nVidia driver or driver update issue.

2. This is not a P3D issue.

Why is that? Because, if it was e genuine nVidia or P3D issue, it would affect everyone and we would see hundreds of reports, including from your truly.

I am fully aware that I might be starting a flame war here, but facts are facts, no matter how uncomfortable they are.

And don't even for a moment think that I am laughing my butt off writing this....

Jorgen
System: i7-7700K @ 4.66 GHz, ASUS Z170-A motherboard, 16 GB 3200 MHz DDR4 RAM, nVidia GTX 960 w/ 4 GB DDR5 VRAM, Windows 10 Home.

All views and opinions expressed here are entirely my own. I am not a Lockheed-Martin employee.

natoseigh
Posts: 3
Joined: Fri Jul 17, 2015 5:58 pm

Re: Missing Shaders Directory

Postby natoseigh » Fri Jun 26, 2020 9:44 am

After seeing these reports about the HLSL shaders folder suddenly gone, I decided to check this also on my system.

I upgraded to the latest nVidia driver on the 24th, and did not see any issue with the upgrade or after that.

So this morning (local time) I flew both v. 4.5 HF3 and v. 5 HF2 without seeing any errors at all.

Also, the number of reports we have in these forums of this issue is below a dozen.

The conclusion therefore is this:

1. This is not an nVidia driver or driver update issue.

2. This is not a P3D issue.

Why is that? Because, if it was e genuine nVidia or P3D issue, it would affect everyone and we would see hundreds of reports, including from your truly.

I am fully aware that I might be starting a flame war here, but facts are facts, no matter how uncomfortable they are.

And don't even for a moment think that I am laughing my butt off writing this....

Jorgen



Is there a way to solve it

JorgenSA
Posts: 2732
Joined: Sun Mar 11, 2018 7:17 am
Location: 5 NM NE of EDXF

Re: Missing Shaders Directory

Postby JorgenSA » Fri Jun 26, 2020 9:57 am

In a couple of cases, this has been associated with installation of EZDOK and with the installation of add-on aircraft.

In other cases, the users did not report any apparent cause.

If this has happened seemingly during or immediately after an add-on installation, the first point of contact should be the add-on manufacturer, as they would want to know if their product causes such an issue.

This does not constitute finger-pointing at any add-on manufacturer!

This issue is brand new, so we don't know too much about what happens yet.

Jorgen
System: i7-7700K @ 4.66 GHz, ASUS Z170-A motherboard, 16 GB 3200 MHz DDR4 RAM, nVidia GTX 960 w/ 4 GB DDR5 VRAM, Windows 10 Home.

All views and opinions expressed here are entirely my own. I am not a Lockheed-Martin employee.

User avatar
Simbol
Posts: 701
Joined: Thu Sep 07, 2017 10:24 pm
Location: UK
Contact:

Re: Missing Shaders Directory

Postby Simbol » Fri Jun 26, 2020 10:19 am


Matt

List all the add-on's you have installed in your simulator.

S.
Image
CEO Flight Sim Technologies Ltd
Oficial Website: https://www.FSReborn.com

User avatar
Martyson
Posts: 10074
Joined: Sun Mar 25, 2012 11:08 am

Re: Missing Shaders Directory

Postby Martyson » Fri Jun 26, 2020 11:11 am

Also, just to verify, which folder is missing?:

D:\Prepar3D v4\ShadersHLSL

C:\Users\myname\AppData\Local\Lockheed Martin\Prepar3D v4\Shaders
Best Regards,
Vaughan Martell (KDTW)

User avatar
Simbol
Posts: 701
Joined: Thu Sep 07, 2017 10:24 pm
Location: UK
Contact:

Re: Missing Shaders Directory

Postby Simbol » Fri Jun 26, 2020 12:00 pm

Also what antivirus or security software you guys are using?

S.
Image
CEO Flight Sim Technologies Ltd
Oficial Website: https://www.FSReborn.com

JorgenSA
Posts: 2732
Joined: Sun Mar 11, 2018 7:17 am
Location: 5 NM NE of EDXF

Re: Missing Shaders Directory

Postby JorgenSA » Fri Jun 26, 2020 12:25 pm

I am using the paid version of AVG.

Jorgen
System: i7-7700K @ 4.66 GHz, ASUS Z170-A motherboard, 16 GB 3200 MHz DDR4 RAM, nVidia GTX 960 w/ 4 GB DDR5 VRAM, Windows 10 Home.

All views and opinions expressed here are entirely my own. I am not a Lockheed-Martin employee.

User avatar
Simbol
Posts: 701
Joined: Thu Sep 07, 2017 10:24 pm
Location: UK
Contact:

Re: Missing Shaders Directory

Postby Simbol » Fri Jun 26, 2020 12:47 pm

I am using the paid version of AVG.

Jorgen
And you are having this issue Jorgen?

Regards,
Simbol
Image
CEO Flight Sim Technologies Ltd
Oficial Website: https://www.FSReborn.com

JorgenSA
Posts: 2732
Joined: Sun Mar 11, 2018 7:17 am
Location: 5 NM NE of EDXF

Re: Missing Shaders Directory

Postby JorgenSA » Fri Jun 26, 2020 12:53 pm

No, I do not have this issue.

I updated the nVidia driver on the 24th, and have flown v. 4.5 HF3 and v. 5 HF2 multiple times since.

Jorgen
System: i7-7700K @ 4.66 GHz, ASUS Z170-A motherboard, 16 GB 3200 MHz DDR4 RAM, nVidia GTX 960 w/ 4 GB DDR5 VRAM, Windows 10 Home.

All views and opinions expressed here are entirely my own. I am not a Lockheed-Martin employee.

User avatar
Simbol
Posts: 701
Joined: Thu Sep 07, 2017 10:24 pm
Location: UK
Contact:

Re: Missing Shaders Directory

Postby Simbol » Fri Jun 26, 2020 12:58 pm

We suspect an antivirus solution is removing the folder when the content of the folder is accessed.

Can people with this issue please inform what anti-virus are they using, remove it (uninstall it) temporally and try again to see if the issues resolved? also it would be useful to know the antivirus product being used..

S.
Image
CEO Flight Sim Technologies Ltd
Oficial Website: https://www.FSReborn.com

User avatar
Simbol
Posts: 701
Joined: Thu Sep 07, 2017 10:24 pm
Location: UK
Contact:

Re: Missing Shaders Directory

Postby Simbol » Fri Jun 26, 2020 1:33 pm

** Update **

please do this: https://www.prepar3d.com/forum/viewtopi ... 4&t=138705

Regards,
S.
Image
CEO Flight Sim Technologies Ltd
Oficial Website: https://www.FSReborn.com

Megdun
Posts: 3
Joined: Fri Apr 07, 2017 11:23 pm

Re: Missing Shaders Directory

Postby Megdun » Sat Jun 27, 2020 6:40 am

** Update **

please do this: https://www.prepar3d.com/forum/viewtopi ... 4&t=138705

Regards,
S.
Well this Seems to have helped S. Thankyou. Will post if there are any other issues after it rebuilds the scenery

Thanks Heaps

Matt


Return to “Prepar3D Installation and Installer Questions”

Who is online

Users browsing this forum: No registered users and 32 guests