After 5.2 install user external lights go dark

Any issues, problems or troubleshooting topics related to installing the Prepar3D client application or it's installer.
Post Reply
sdj2fly
Posts: 3
Joined: Sat Jun 19, 2021 5:23 am

After 5.2 install user external lights go dark

Post by sdj2fly »

I installed 5.2 a week ago and I just noticed that when flying at night I have no taxi or landing lights visible from the cockpit. When I look at the aircraft externally only the cabin lights are on from the textures but no other lights. The aircraft is totally dark. This is for default aircraft as well as addon. I notice that the AI aircraft are all lighted up. I am considering reverting back to 5.1 as 5.1 was just fine for me. Except I don't quite know how to do that. I would rather see this problem resolved before I revert back to 5.1. There are other problems also.
ReinFlight
Posts: 11
Joined: Thu Apr 23, 2020 7:38 am

Re: After 5.2 install user external lights go dark

Post by ReinFlight »

I have the same problem. I can switch the lights on (landing, taxi, beacon, strobe, nav) I can see they are turned on, but landing and taxilights don't illuminate the ground. Dynamic lights are on. Tried already a lot of things but no success so far. The problem occurs also with default ac. I tried the Mooney. Ik hope someone can come up with a solution to fix it.
sdj2fly
Posts: 3
Joined: Sat Jun 19, 2021 5:23 am

Re: After 5.2 install user external lights go dark

Post by sdj2fly »

Ok, with the absence of any solution by LM, it would seem that this problem will not be resolved soon. So I am just going to revert back to 5.1 which was working fine. I notice there are other anomolies with 5.2 so I will give LM some months to resolve these problems while I hopefully will be flying 5.1.
The only lights that will work in my tests are the cockpit and cabin lights and the logo lights sometimes. Beacons, strobes, nav, taxi, landing lights are not present. So, this is something that will take some time for LM to solve.
sdj2fly
Posts: 3
Joined: Sat Jun 19, 2021 5:23 am

Re: After 5.2 install user external lights go dark

Post by sdj2fly »

Hot diggity dog! I was just about to uninstall 5.2 and then reinstall 5.1 when I thought of the "effects" folder. I looked in the "effects" folder and found 49 items and only 2 items in its "texture' folder. Then I checked my backup external drive and found that my "effects" folder had 559 items and its texture folder had 49 items. So, I copied the whole content of my "effects" folder from backup to 5.2 and loaded the sim and , sure enough, all the lights are on and viewable from the cockpit. And also the taxi and landing lights and the beacons, strobes, nav, are also on. In fact, lights are better rendered at night in 5.2 than 5.1 once the aircraft lights are back. I guess the update installer misses the effects folder or something.
It is important, before installing 5.2 or any update, to backup the external and scenery and texture folders. If not you will probably have to make a fresh install and also reinstall all of your addons.
Post Reply