Page 1 of 1

DXGI_ERROR_DEVICE_HUNG

Posted: Fri Aug 14, 2020 4:47 pm
by cianliverpool
Everytime I do a flight I seem to get this error. It's happened mostly with FsLabs A320 so I'm not sure if it's something to do with my graphics card not being able to handle it or something like that aswell as running scenery etc. P3D crashes after I get this error and it's been happening almost every flight.

My specs are :
GTX 1050
I5 4690K @4.1ghz
Asus B85M-G Motherboard
8gb RAM

Re: DXGI_ERROR_DEVICE_HUNG

Posted: Fri Aug 14, 2020 5:16 pm
by JorgenSA
Is your Windows 10 up to v. 2004 with the latest updates?

Is your graphics driver up to the latest from nVidia?

What P3D version is this?

Is your graphics card running at the nVidia clock rate, or did the OEM overclock it, even ever so slightly?

Jorgen

Re: DXGI_ERROR_DEVICE_HUNG

Posted: Sat Oct 03, 2020 9:28 pm
by Puukka
My solution for all GPU errors and flickering simconnect menu was:

Open NVIDIA Control Panel. Click on 3D Settings → Manage 3D settings. Scroll down to the bottom of the list and locate the Threaded Optimization. Change the value to Off.

Hope that helps

Kind regards from Austria
Herbert

Re: DXGI_ERROR_DEVICE_HUNG

Posted: Sun Oct 04, 2020 4:06 am
by Martyson
@ Puukka ,

What was the original (bad) setting?

Mine is Auto, no problems.

Re: DXGI_ERROR_DEVICE_HUNG

Posted: Sun Oct 18, 2020 3:37 am
by jonald
Had this issue regularly over the last month. Tried everything under the sun - turning off things, turning settings down but to no avail. Checking my error log, Microsoft Gamingservices.exe seemed to throw an error before I received the error message in the sim.

Try stopping the "gamingservices" service and see if you still get the error. Now I have 2 4+ hour flights with no issue after removing this. You can't change the service to manual like most so I used another tool to remove it (O&O App buster). Keeping my fingers crossed that this has resolved the issue.

Re: DXGI_ERROR_DEVICE_HUNG

Posted: Sun Oct 18, 2020 7:13 am
by JorgenSA
The file "gamingservices.exe" may not be present on all systems, certainly a search of my C: drive did not find it.

Also, the only service I see when I look at the Windows Local Services is "GameDVR and Broadcast User Service_70d4dea".

Please do not take this wrong, if those files/services ARE on your system, and you have issues, it is worth considering taking action here.

Jorgen

Re: DXGI_ERROR_DEVICE_HUNG

Posted: Sun Oct 18, 2020 8:03 am
by jonald
Thanks Jorgen,

I had these Xbox services and Microsoft Gaming services installed as part of the beta testing for MSFS. I think that the way they interact with DX12 may have caused a conflict when using P3D after an update maybe. I decided to uninstall all of them and so far, no issues with P3D.

I hadn't been able to complete a full flight without the error message appearing somewhere along the flight - after pushback, on take off, landing etc. Now on my 4th test flight and so far, no issues.

During all of the trouble, I would monitor temps and clocks but there didn't seem to be anything out of the ordinary that should have caused the error so was stumped like most of the people here with the same problem.

Would be interesting if others who had the same services as myself to stop them and try flying to see if their troubles stop.

Re: DXGI_ERROR_DEVICE_HUNG

Posted: Sun Oct 18, 2020 8:44 am
by JorgenSA
It looks like the Xbox services come with Windows 10 by default, at least I had them and they were set to Automatic.

As I do not expect to ever have an Xbox, I stopped and disabled these services. I have not seen any adverse effects of this.

Jorgen

Re: DXGI_ERROR_DEVICE_HUNG

Posted: Tue Nov 03, 2020 12:12 am
by Alabamaboy59
Now with 5.1 within visual of runway my sim freezes with the DXGI_ERROR_DEVICE_HUNG error I’m using 2.7/7.3 VRAM I’m thinking it may be a scenery issue but did it at 2 different airports

Re: DXGI_ERROR_DEVICE_HUNG

Posted: Tue Nov 10, 2020 2:43 pm
by EmpireKicking
My solution for all GPU errors and flickering simconnect menu was:

Open NVIDIA Control Panel. Click on 3D Settings → Manage 3D settings. Scroll down to the bottom of the list and locate the Threaded Optimization. Change the value to Off.

Hope that helps

Kind regards from Austria
Herbert
what would that do if you have it Off?

Re: DXGI_ERROR_DEVICE_HUNG

Posted: Tue Nov 10, 2020 3:39 pm
by JorgenSA
@Alabamaboy59,

Is your Windows 10 up to v. 2004, or even better, to v. 20H2? And is your graphics driver, no matter if nVidia or AMD, up to the latest level?

Jorgen