GPU Usage Showing As Less Than 5%

Any issues, problems or troubleshooting topics related to computer hardware and the Prepar3D client application
Martyson
Posts: 9326
Joined: Sun Mar 25, 2012 11:08 am

Re: GPU Usage Showing As Less Than 5%

Postby Martyson » Sat Apr 18, 2020 10:15 pm

Ricardo,

You are welcome.

Glad to hear everything is ok.
Best Regards,
Vaughan Martell (KDTW)

Towerkeeper
Posts: 3
Joined: Fri Oct 06, 2017 1:37 pm

Re: GPU Usage Showing As Less Than 5%

Postby Towerkeeper » Sat Apr 18, 2020 11:21 pm

Perhaps I missed the numbers above, but, curious - what video resolution are you using; and, what frame rates are you getting ?

User avatar
Beau Hollis
Lockheed Martin
Posts: 2127
Joined: Wed Oct 06, 2010 3:25 pm

Re: GPU Usage Showing As Less Than 5%

Postby Beau Hollis » Sun Apr 19, 2020 4:29 am

I think this is just an issue with either windows or the graphics driver not properly reporting usage for Dx12. Something similar was reported by Dx12 users of World of Warcraft. I have seen this kind of low usage stat in task manager on some systems running Win10 1809. Our GPU timers and graphics debugging tools, however indicated heavy use. This might be because P3D has .NET WPF UIs that are hardware accelerated by the .NET run-time which uses an older DirectX version under the hood.
Beau Hollis
Prepar3D Software Architect

Martyson
Posts: 9326
Joined: Sun Mar 25, 2012 11:08 am

Re: GPU Usage Showing As Less Than 5%

Postby Martyson » Sun Apr 19, 2020 10:51 am

I think this is just an issue with either windows or the graphics driver not properly reporting usage for Dx12. Something similar was reported by Dx12 users of World of Warcraft. I have seen this kind of low usage stat in task manager on some systems running Win10 1809. Our GPU timers and graphics debugging tools, however indicated heavy use. This might be because P3D has .NET WPF UIs that are hardware accelerated by the .NET run-time which uses an older DirectX version under the hood.
Beau,
Is there a tool, other than the Task Manager , that pilots can use to check actual performance of Nvidia cards?
Best Regards,
Vaughan Martell (KDTW)

jabloomf1230
Posts: 262
Joined: Thu Nov 01, 2012 7:40 pm

Re: GPU Usage Showing As Less Than 5%

Postby jabloomf1230 » Sun Apr 19, 2020 8:40 pm

It seems to be just the Windows Task Manager. AIDA https://www.aida64.com/ reports GPU use correctly for P3d5, as does Process Explorer, which is a MS replacement for the built-in Task Manager:

https://docs.microsoft.com/en-us/sysint ... s-explorer

Towerkeeper
Posts: 3
Joined: Fri Oct 06, 2017 1:37 pm

Re: GPU Usage Showing As Less Than 5%

Postby Towerkeeper » Sun Apr 19, 2020 9:11 pm

I think this is just an issue with either windows or the graphics driver not properly reporting usage for Dx12. Something similar was reported by Dx12 users of World of Warcraft. I have seen this kind of low usage stat in task manager on some systems running Win10 1809. Our GPU timers and graphics debugging tools, however indicated heavy use. This might be because P3D has .NET WPF UIs that are hardware accelerated by the .NET run-time which uses an older DirectX version under the hood.
Probably that's what I'm seeing also. System is an Asus ROG V10 with a 6850K, two RTX 2080Ti's (in SLI) driving three 4k monitors. With most sliders maxed or nearly so, I'm getting 40fps, and it's very smooth. Yet the GPU usage is measuring low - all system fans running fast though. Will have to add another screen to view all this is real time.

Kudos to your group there. Does your software/pipeline make any use of SLI ?

Towerkeeper (a.k.a. Larry)

Martyson
Posts: 9326
Joined: Sun Mar 25, 2012 11:08 am

Re: GPU Usage Showing As Less Than 5%

Postby Martyson » Mon Apr 20, 2020 7:43 am

It seems to be just the Windows Task Manager. AIDA https://www.aida64.com/ reports GPU use correctly for P3d5, as does Process Explorer, which is a MS replacement for the built-in Task Manager:

https://docs.microsoft.com/en-us/sysint ... s-explorer
I previously used Process Explorer a lot in past sim(s) versions when OOms were an issue.

Since WIN10 I have seldom used it.

I checked Process Explorer and Task Manager reporting (XP11 and P3Dv5) and both are nearly identical on my tests.
Best Regards,
Vaughan Martell (KDTW)

User avatar
Beau Hollis
Lockheed Martin
Posts: 2127
Joined: Wed Oct 06, 2010 3:25 pm

Re: GPU Usage Showing As Less Than 5%

Postby Beau Hollis » Mon Apr 20, 2020 2:34 pm

To get a accurate stats for Dx12 you need to switch the graph in the task manager to show the DirectX12 Direct/Graphics Command Queue usage "Graphics_1":
- Open Task Manager
- Click on Performance Tab
- Click on the down arrow next to "3D" on the top left graph
- Select Graphics_1

You can also set one of the other graphics to Compute_1 to see usage of the compute queue. We use this for particles effect simulation and rain/snow but it's generally pretty small part of the frame.
Beau Hollis
Prepar3D Software Architect

Martyson
Posts: 9326
Joined: Sun Mar 25, 2012 11:08 am

Re: GPU Usage Showing As Less Than 5%

Postby Martyson » Mon Apr 20, 2020 2:47 pm

Beau,

Thanks for the Task Manager 3D information.

I checked it and it works.

I will use your instructions in the future.
Best Regards,
Vaughan Martell (KDTW)

jabloomf1230
Posts: 262
Joined: Thu Nov 01, 2012 7:40 pm

Re: GPU Usage Showing As Less Than 5%

Postby jabloomf1230 » Fri Apr 24, 2020 1:56 am

It seems to be just the Windows Task Manager. AIDA https://www.aida64.com/ reports GPU use correctly for P3d5, as does Process Explorer, which is a MS replacement for the built-in Task Manager:

https://docs.microsoft.com/en-us/sysint ... s-explorer
I previously used Process Explorer a lot in past sim(s) versions when OOms were an issue.

Since WIN10 I have seldom used it.

I checked Process Explorer and Task Manager reporting (XP11 and P3Dv5) and both are nearly identical on my tests.
Well, that's not my experience. Only Task Manager reports %GPU at an extremely low number and Beau explained how to fix that. BTW, Process Explorer was most recently updated in December, 2019.

jabloomf1230
Posts: 262
Joined: Thu Nov 01, 2012 7:40 pm

Re: GPU Usage Showing As Less Than 5%

Postby jabloomf1230 » Fri Apr 24, 2020 5:19 pm

I've checked further on this and most 3rd party apps that list GPU usage, interrogate the GPU directly, without requesting information from an intermediate layer such as either DirectX, OpenGL or Vulkan. The Task Manager does not by default, but it also provides more flexibility as to what information is available.

Ricardo777
Posts: 23
Joined: Fri Nov 11, 2016 3:50 pm

Re: GPU Usage Showing As Less Than 5%

Postby Ricardo777 » Tue May 12, 2020 6:28 pm

Just got a chance to come back to this thread, thank you so much for the help this works exactly as stated. Thanks again and thanks for creating an amazing product, V5 is simply amazing.

danosti
Posts: 5
Joined: Thu May 14, 2020 2:40 pm

Re: GPU Usage Showing As Less Than 5%

Postby danosti » Thu May 14, 2020 2:58 pm

Gday I'm getting a simular issue with my 2 GPUs .
Just Put up a New post.
Cheers Daniel

Ricardo777
Posts: 23
Joined: Fri Nov 11, 2016 3:50 pm

Re: GPU Usage Showing As Less Than 5%

Postby Ricardo777 » Thu May 14, 2020 7:18 pm

Hi Daniel the suggestion in this thread from the Prepar3d team was;
- Open Task Manager
- Click on Performance Tab
- Click on the down arrow next to "3D" on the top left graph
- Select Graphics_1
That worked for me so massive thanks to Beau Hollis for this tip! Really helpful and congratulations to the team for creating a truly amazing sim in V5.

danosti
Posts: 5
Joined: Thu May 14, 2020 2:40 pm

Re: GPU Usage Showing As Less Than 5%

Postby danosti » Thu May 14, 2020 11:52 pm

Hi Ricardo

I did see that in earlier in this post.
I did try it and no luck .
Might have something to do with having 2 GPUs in SLI ?
The first GPU displays just fine and yet the SIM runs pretty dam good .
It’s weird that my second GPU is stuck on 0% .
A massive improvement from V4 .
Well does to the lads .....
Any way I have a seperate post on this problem that is open so hopefully there is a solution .


Return to “Hardware Specific Questions”

Who is online

Users browsing this forum: No registered users and 15 guests