VR Cursor no longer visible after 5.2 and 5.2 hotfix

Any issues, problems or troubleshooting topics related to computer hardware and the Prepar3D client application
Post Reply
quid21
Posts: 46
Joined: Wed Dec 11, 2013 7:03 pm
Location: Newmarket, UK
Contact:

VR Cursor no longer visible after 5.2 and 5.2 hotfix

Post by quid21 »

I updated the Client only on each occasion, but I no longer see the VR mouse cursor, which renders VR pretty unusable.

Is there any fix for that?

I understand it should be on by default, and it was visible previously prior to the update.
dacia123
Posts: 2
Joined: Thu Jul 08, 2021 9:57 pm

Re: VR Cursor no longer visible after 5.2 and 5.2 hotfix

Post by dacia123 »

Same here, no mouse coursor anymore.

I have P3Dv5.2 and the VR hotfix for WMR installed.
Its smooth, but the mouse pointer is gone.

Any fix?

Thanks a lot :)
Willie Nelson
Posts: 20
Joined: Sat Feb 11, 2017 5:07 am

Re: VR Cursor no longer visible after 5.2 and 5.2 hotfix

Post by Willie Nelson »

I have the same problem and have mentioned it in other queries but I'm not getting a lot of answers. A short term work around is to set your default aircraft to something different and that brought it back for me. Not a great long term fix though.
Willie Nelson
Posts: 20
Joined: Sat Feb 11, 2017 5:07 am

Re: VR Cursor no longer visible after 5.2 and 5.2 hotfix

Post by Willie Nelson »

It was also occurring in 5.1 for me. On occasion, I can see the cursor down the bottom of the HMD display but it cannot be moved so it certainly seems like a bug.

I use WMR and SteamVR and it works great for the default aircraft scenario but when I switch, I am often looking at a black monitor with the menu options at the top and the cursor can be moved on the monitor but remains invisible within the HMD.

I have also tried toggling WIN+Y without success. I have also tried toggling in and out of full screen.
Willie Nelson
Posts: 20
Joined: Sat Feb 11, 2017 5:07 am

Re: VR Cursor no longer visible after 5.2 and 5.2 hotfix

Post by Willie Nelson »

Sorry, looks like I had my "hit distance" on the cursor set incorrectly. Not sure if that helps anyone else.
hardbotj
Posts: 2
Joined: Fri Jul 23, 2021 10:21 am

Re: VR Cursor no longer visible after 5.2 and 5.2 hotfix

Post by hardbotj »

Yeah, no cursor here for me either. Was working previously but now gone.

VR settings all at default, tried reinstalling client etc. but no luck.
hardbotj
Posts: 2
Joined: Fri Jul 23, 2021 10:21 am

Re: VR Cursor no longer visible after 5.2 and 5.2 hotfix

Post by hardbotj »

FYI Looks like I have sorted it.

Removed the VR hotfix (which I tried previously) but this time remembered to reverse the CFG setting LoadVirtualReality back to =1 and the VR cursor appears as it should.
quid21
Posts: 46
Joined: Wed Dec 11, 2013 7:03 pm
Location: Newmarket, UK
Contact:

Re: VR Cursor no longer visible after 5.2 and 5.2 hotfix

Post by quid21 »

hardbotj wrote: Sat Jul 24, 2021 3:48 am FYI Looks like I have sorted it.

Removed the VR hotfix (which I tried previously) but this time remembered to reverse the CFG setting LoadVirtualReality back to =1 and the VR cursor appears as it should.
Thanks will try that - for anyone else who cannot remember how to do that:

To Disable this add-on and re-enable the default Virtual Reality dll:
1) In Prepar3D Menu, click Options->Add-ons
2) Uncheck the Virtual Reality Hotfix add-on
3) Shut-down Prepar3D. Follow the instructions in step 2 to modify the Prepar3D.cfg
a) Change LoadVirtualReality=0 back to LoadVirtualReality=1
Post Reply