Thrustmaster TCA Airbus sidestick axes issues

Any issues, problems or troubleshooting topics related to computer hardware and the Prepar3D client application
Post Reply
upnaway
Posts: 5
Joined: Thu May 16, 2019 11:52 am

Thrustmaster TCA Airbus sidestick axes issues

Post by upnaway »

Hi there,

A few days ago I've bought the Thrustmaster TCA Airbus sidestick and installed in on my P3D v4.5.
Unfortunately I've trouble with the axes.
All control surfaces (aileron, eleveator, ...) as well as the thrust lever shiver and jump forward and back during moving the corresponding axis on the sidestick!
This occurs on all aircraft models.
When I use the Win 10 (20H2) calibration tool I can see the cursor is moving very smooth throughout the field.
Hence it doesn't seem to be a problem of the hardware itself.

I've tested the sidestick also in FSX on a further system partition with Win 8.1 with the same result.

For test purposes I've setup Windows 10 from the scratch on a free partition and installed also FSX.
In that configuration the sidestick works like a charm!!

Maybe there's something in my P3D (controls) configuration which causes the problems?
In any configuration file I could find I deleted the old Cyborg controller. But that doesn't help.

Has someone out there any idea?
Thx in advance!
User avatar
Martyson
Posts: 11557
Joined: Sun Mar 25, 2012 11:08 am

Re: Thrustmaster TCA Airbus sidestick axes issues

Post by Martyson »

@ upnaway ,

Just for follow up on my setup.

I have the Thrustmaster TCA Airbus sidestick and throttles.
I used FSUIPC (registered) to set up everything without a problem on my P3Dv4.5HF3 install.

Note:
I only use it on the FSLabs A320 on my setup.
Other aircraft types use other controllers.


Have you searched this forum for additional information?

The search function in P3D is here (or you can also use your favorite Internet search engine):

Image
Best Regards,
Vaughan Martell PP-ASEL (KDTW)
Post Reply