Other problems or issues not covered by other troubleshooting topics.
Posts: 2
Joined: Thu Dec 15, 2011 11:14 am

Postby eugene » Wed Dec 28, 2011 4:42 pm

I have d/l the P3D demo and when I try to start it up I get the following"Can't find FSX in the registery", OK and I'm out.

FSX is, a legal copy, installed on my J drive and SP1 and SP2 are installed. I have been told that I don't need FSX to run P3D.

Can anyone help to sort this out?. Before I have to beg my wife to buy this, I would like to see it.

In FSX I like to fly low and slow. I am an ex-serviceman in the RCAF , many years ago, and only flew piston aircraft.



Posts: 185
Joined: Tue Nov 22, 2011 7:51 am

Postby Burkhard » Thu Dec 29, 2011 5:15 am

It may be you have to wait until after New Year since the specialists announced they are on holiday. You are sure the user who runs P3D is the same user as the one who installed it, and has full administrative rights? If not I could understand it not working and the wrong error message to come from deep inside some routines...

Posts: 48
Joined: Fri Nov 12, 2010 7:57 pm

Postby Francois » Thu Dec 29, 2011 6:05 am

Maybe yo 'moved' FSX to another location than originally installed? Or your ergistry has become corrupt for some other reason (that is KNOWN to happen.. *grin*).... in that case you can try to use the Flight1 utility that will fix FSX back into your registry.

You can download it from their services page on their site here: http://www.flight1.com/view.asp?page=library

Legacy Support
Posts: 474
Joined: Mon Aug 16, 2010 7:22 pm

Postby Legacy Support » Thu Dec 29, 2011 11:37 am

Hi Eugene,

This is a very unusual issue and we have not seen it before. What operating system are you using? I assume that when you say "P3D Demo" you are using one of the promo codes to download and activate the license from the Prepar3D website?

Have you used any registry tools to shift your installation of FSX to your J drive in the past? I would tend to think that it is a registry issue as Francois indicates, but fall-back would probably be to redownload after deleting your previous download and clearing your cache from your temp files and re-install following the installation instructions.


Posts: 2
Joined: Thu Dec 15, 2011 11:14 am

Postby eugene » Thu Dec 29, 2011 3:04 pm

Thanks John

I'm using Win7 64bit. I've got 6gig ram and a 1024 meg graphics card.. I have tried to install twice with the same result.

I was going to try and d/l again.


Posts: 1
Joined: Tue Apr 03, 2012 3:19 pm

Postby mace » Tue Apr 03, 2012 12:56 pm

Hi eugene,

Have you solved this problem?

Im having same problem here.

Hope there are something to do with this.


Posts: 15
Joined: Fri Aug 19, 2011 2:22 pm

Postby ChrisHMeyer » Thu Apr 05, 2012 3:07 pm

Hi Mace,

Couple of things to try:

1) Be sure to thoroughly go through the Prepar3d Install Guide located here: http://www.prepar3d.com/wp-content/uploads/2012/03/Prepar3D_Download_and_Install_Instructions.pdf. It has a few things you can try to help fix the issue.

2) For Win7 64-bit systems, execute the 'regedit' tool by typing it into the 'Search programs and files' field in the Windows Start Menu. Check the key at the following location: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\LockheedMartin\Prepar3D. The SetupPath must be equal to your install/execution directory for Prepar3d.

We see this problem happen sometimes when users have multiple versions of Prepar3d installed, have problems uninstalling other copies when upgrading, manually drag-and-drop Prepar3d system files to other locations, or try to use network / virtual drives on a system that change every bootup without Prepar3d's knowledge. Hope this info helps solve your issue.


Christopher Meyer

Prepar3d Developer

Return to “Other Support Questions”

Who is online

Users browsing this forum: Google [Bot] and 54 guests