Page 2 of 2

Posted: Fri Nov 29, 2013 4:08 pm
by chris512
Has anyone found a solution to this problem? My Scenery Library in Prepar3d v2 is a right mess. Having the same problems as described here. If I look in my Scenery.cfg the entries only go up to 125. That's just the default stuff. I've looked at the main .cfg in the Prepar3d folder and also the one in the hidden "Roaming" folder. Both are only showing 125 entries. I have added quite a lot of add on scenery. It was working fine until I tried to move stuff about in the scenery library window!

Posted: Fri Nov 29, 2013 4:26 pm
by earnorbust
I think you are in the wrong Folder Chris. On Windows 7/8 you can only change the scenery.cfg located at ...%bootroot%\ProgramData\Lockheed Martin\prepar3d v2\ ...and NOT in the program install location at ...%program%\Lockheed Martin\Prepar3d vp (the file there ist used from the program internally - you must leave it be!)

And as for now don't use the scenery library Editor in the menu bar, because it is faulty. Make changes outside of Prepar3d v2 manually with a text Editor or better - use "Addit! pro" (because it can renumber all layers!) Addit! pro works with Prepar3d v1.4, but can be used with Prepar3d v2 by moving the scenery.cfg to a readable location (it isn't yet capable of reading the .../ProgramData Folder) to edit the Content and then moving the scenery.cfg back to it's original location before starting the sim.

Hope I made the subject understandable ;-)


Posted: Fri Nov 29, 2013 6:01 pm
by chris512
Hi Robert, Thanks for the response. I'm not sure where to find "%bootroot%\ProgramData\Lockheed Martin\prepar3d v2\" but I'll have a look. I've done a Repair on Prepar3d and that didn't help. I've uninstalled all of my scenery now so hopefully after a reinstall it'll all be ok. Once I've found the location you posted for the .cfg file hopefully I can avoid any more problems. Thanks.

Posted: Fri Nov 29, 2013 6:06 pm
by earnorbust
The %bootroot% is nothing else then the drive from which you boot your Computer from.

I use Windows 7 and boot from my drive C:

So my scenery.cfg ist located at: C:\ProgramData\Lockheed Martin\Prepar3d v2\scenery.cfg (yours probable too)


Posted: Fri Nov 29, 2013 6:50 pm
by chris512
Thanks Robert, I've actually doing a full reinstall of everything now. It needed doing anyway to be honest. I'm getting rid of FSX too. At least I know where to look if it goes wrong again. Thanks.

Posted: Sun Dec 08, 2013 10:43 am
by Rockme
I also could not add anything anymore, and the problem looks like was MY TRAFFIC 2013 add on, since I reinstalled everything of course without MT2013 everything works fine now!!MT2013 destroys your scenery library!!!!

Posted: Mon Mar 02, 2015 12:01 pm
by darbelux
i got format my PC and fresh install windows 8.1, then just install P3D v2.5 and i have same error and i can't access to scenery library for this i can't add my custom sceneries.. im just read "Unable to open C:\programData\Lockheed Martin\Prepar3d V2\Scenery.cfg for reading". Please help...

Posted: Tue Mar 03, 2015 9:07 am
by soulmaril
I have been experiencing this problem since the first 2.0 release. I reported several times. Sorry but it is been ignored. That's why I give up.

Posted: Tue Mar 03, 2015 7:06 pm
by hermes82
I followed Saul's advice and made an addon scenery folder outside of p3d's main folder, p3d is installed on a wd velociraptor and not on c drive but addon scenery is on c, the scenery is just added once in the cockpit but I do get a ctd but after restarting the scenery is loaded, my scenery cfg has 186 entries, there are also 4 old scenery files in the same folder, if you do make an addon scenery folder outside p3d's main folder don't forget to add the addon folder from the world, scenery library and make sure it's at the top of the list

Posted: Wed Mar 04, 2015 12:57 am
by darbelux
i can add my add-on scenery when i edit scenery.cfg but, with this method scenery airport's ILS/VOR data now showing on my GPS screen there is nothing! and i can't select.. im going to give up.. LM must fix this issue immediately...