dxgi_error_device_hung - Error

Any issues, problems or troubleshooting topics related to the Prepar3D client application.
NobuMa
Posts: 15
Joined: Sat Jul 07, 2018 2:09 pm

dxgi_error_device_hung - Error

Postby NobuMa » Thu Aug 09, 2018 1:53 pm

Good day P3D forum,
I have a problem with my P3D client. My P3D crashes randomly with this error report "This device (NVIDIA GeForce GTX 750 Ti) stopped working for the following reason: dxgi_error_device_hung." And P3D stop working.
Is there any solution? I hope...

My GPU:
Nvidia GTX 750 Ti v398.82 (newest)

and I owns the addons:
- IvAp
- Orbx products (I think it's not)
- Chaseplane
- PMDG 737NGX

Have a nice day!

Your NobuMa

Martyson
Posts: 5677
Joined: Sun Mar 25, 2012 11:08 am

Re: dxgi_error_device_hung - Error

Postby Martyson » Thu Aug 09, 2018 2:00 pm

Good day P3D forum,
I have a problem with my P3D client. My P3D crashes randomly with this error report "This device (NVIDIA GeForce GTX 750 Ti) stopped working for the following reason: dxgi_error_device_hung." And P3D stop working.
Is there any solution? I hope...

My GPU:
Nvidia GTX 750 Ti v398.82 (newest)

and I owns the addons:
- IvAp
- Orbx products (I think it's not)
- Chaseplane
- PMDG 737NGX

Have a nice day!

Your NobuMa
Which version of P3D?

Have you searched the forum?
Best Regards,
Vaughan Martell (KDTW)

NobuMa
Posts: 15
Joined: Sat Jul 07, 2018 2:09 pm

Re: dxgi_error_device_hung - Error

Postby NobuMa » Thu Aug 09, 2018 2:07 pm

Newest version of P3D. And yes I did.

User avatar
Brady Butler
Lockheed Martin
Posts: 901
Joined: Tue May 09, 2017 5:31 pm

Re: dxgi_error_device_hung - Error

Postby Brady Butler » Thu Aug 09, 2018 2:08 pm

Hello,

Did you update your graphics drivers? This error message usually points to a hardware/driver error.

Regards,
Brady
Brady Butler
Prepar3D® Software Engineer

NobuMa
Posts: 15
Joined: Sat Jul 07, 2018 2:09 pm

Re: dxgi_error_device_hung - Error

Postby NobuMa » Thu Aug 09, 2018 2:10 pm

Yes, I do. It's at newest version (v398.82)

User avatar
Brady Butler
Lockheed Martin
Posts: 901
Joined: Tue May 09, 2017 5:31 pm

Re: dxgi_error_device_hung - Error

Postby Brady Butler » Thu Aug 09, 2018 2:26 pm

Ah, I missed that in your original post.

Did you try the solutions in these threads?
viewtopic.php?f=6315&t=126943&hilit=dxg ... evice_hung
viewtopic.php?f=6315&t=126943&hilit=dxg ... evice_hung

Sometimes add-ons can cause this error, sometimes the driver, and sometimes the hardware itself. It is a hard one to pin down. Let us know if the posts help you fix your error.

Regards,
Brady
Brady Butler
Prepar3D® Software Engineer

NobuMa
Posts: 15
Joined: Sat Jul 07, 2018 2:09 pm

Re: dxgi_error_device_hung - Error

Postby NobuMa » Tue Aug 14, 2018 5:07 pm

I tried DDU to clean my nvidia device and install it new. Still happens same problem :(

User avatar
Brady Butler
Lockheed Martin
Posts: 901
Joined: Tue May 09, 2017 5:31 pm

Re: dxgi_error_device_hung - Error

Postby Brady Butler » Tue Aug 14, 2018 5:56 pm

Hello NobuMa,

Have you tried removing/uninstalling all of your add-ons? Is your GPU overheating?

Regards,
Brady
Brady Butler
Prepar3D® Software Engineer

NobuMa
Posts: 15
Joined: Sat Jul 07, 2018 2:09 pm

Re: dxgi_error_device_hung - Error

Postby NobuMa » Tue Aug 14, 2018 6:30 pm

No, I did not. I have a lot of AddOns and I don't want to install it again if still same problem..
And no my GPU is not overheating.

JPS2K5
Posts: 15
Joined: Fri Jul 07, 2017 8:07 am

Re: dxgi_error_device_hung - Error

Postby JPS2K5 » Wed Aug 15, 2018 7:25 am

I'm not 100% sure this is what actually helped for me, but I had these too, and so far for the last week I haven't had it once. And this is an easy thing to try.

I discovered that DDU didn't uninstall nvcuda.dll and some (2 or 3) files around it in windows\system32. I manually deleted these, reinstalled my driver and no problems since.

shermank
Posts: 40
Joined: Thu Nov 28, 2013 6:17 pm

Re: dxgi_error_device_hung - Error

Postby shermank » Wed Aug 15, 2018 11:45 am

I am not going to pretend that I know more than the real techie experts, but I have more or less solved this problem by rolling back from the newer Nvidia drivers to the 367.64.

Granted, each installation is different. But for my rig, this seems to work well. I have also turned off vsync and set my fps at 60 which matches the refresh rate on my monitor.

Because the gods are what they are :-), I will probably see the dxgi error return because I posted this....

Sherm

Martyson
Posts: 5677
Joined: Sun Mar 25, 2012 11:08 am

Re: dxgi_error_device_hung - Error

Postby Martyson » Wed Aug 15, 2018 12:32 pm

I am not going to pretend that I know more than the real techie experts, but I have more or less solved this problem by rolling back from the newer Nvidia drivers to the 367.64.

Granted, each installation is different. But for my rig, this seems to work well. I have also turned off vsync and set my fps at 60 which matches the refresh rate on my monitor.

Because the gods are what they are :-), I will probably see the dxgi error return because I posted this....

Sherm
Nvidia driver 367.64 or 397.64 (May 2018)?

Notes :
I have used Nvidia drivers (all ok here, never had a DXGI error) with FSX Accel, P3Dv3.4, P3Dv4.2, P3Dv4.3 and Win7-64 Pro:

388.71 (and previous drivers)
390.77
391.24
391.35
387.64
397.93
398.11 as of June 16 2018
398.36
398.82 8-9-18 P3Dv4.3 and other Sims (currently no problems to report).
Best Regards,
Vaughan Martell (KDTW)

NobuMa
Posts: 15
Joined: Sat Jul 07, 2018 2:09 pm

Re: dxgi_error_device_hung - Error

Postby NobuMa » Thu Aug 16, 2018 12:09 pm

I'm not 100% sure this is what actually helped for me, but I had these too, and so far for the last week I haven't had it once. And this is an easy thing to try.

I discovered that DDU didn't uninstall nvcuda.dll and some (2 or 3) files around it in windows\system32. I manually deleted these, reinstalled my driver and no problems since.
Which one exactly?

@shermank I try to disable vsnyc and set fps to 60.

I can't find v367.64 but I did reinstall to 397.64 (May 2018). If the problem is still here, will report.

I need to test it

NobuMa
Posts: 15
Joined: Sat Jul 07, 2018 2:09 pm

Re: dxgi_error_device_hung - Error

Postby NobuMa » Fri Aug 24, 2018 6:09 pm

The problem was looks like solved. But today I got this error again :(

But the older version supported me to reduce this errors but not fixed yet.


Return to “Prepar3D Client Application Questions”

Who is online

Users browsing this forum: No registered users and 17 guests