Page 1 of 1

VR zoom issues

Posted: Sun Jul 01, 2018 11:34 am
by gcbraun
Hello, I have assigned a joystick button to VR zoom. While it works, sometimes the zoom resets on its own. This happens both when I keep pressing the VR zoom button or when I let it go.

It seems to be completely random and happens after a few or many seconds. Sometimes it stays zoomed, sometimes not.

Is this a known issue?

Thanks

Re: VR zoom issues

Posted: Sun Jul 01, 2018 12:47 pm
by Hippo
Sorry for not answering your question, but I'll describe what I've done in case it helps.

I'm very happy with how DCS does VR zoom and have tried to emulate the same system here.

What I did is assign a keypress to ZOOM_PLUS and another to ZOOM_1X (through fsuipc):

118=90,8,65719,0 -{Z: Press=ZOOM_PLUS }-
120=90,10,65550,0 -{ctl+Z: Press=ZOOM_1X }-

I then assigned the first keypress (just one quick press, not a hold) to a press action on a joystick button, and the second to the release action (using my x52 pro joystick software). So (as with DCS) I hold down the button to zoom in, and release to return to default. This has been working flawlessly for me so far.

Re: VR zoom issues

Posted: Sun Jul 01, 2018 12:54 pm
by gcbraun
That is exactly what I was looking for. Now it works just like XP11/DCS.

I just changed the Release function to ZOOM_MINUS.

Thanks!