Issues with night lighting after 3.4

Any issues, problems or troubleshooting topics related to the Prepar3D client application.
Adam Breed
Lockheed Martin
Posts: 1385
Joined: Mon Sep 20, 2010 6:17 pm

Re: Issues with night lighting after 3.4

Postby Adam Breed » Thu Oct 27, 2016 1:09 pm

Chok,

After some experimentation, we believe the issue might be with one of the tools that are third party developed to switch on and off bgls. Unfortunately, we don't have much insight on how that is being triggered. You will see some scenery items with the extension changed to .off (e.g. omdb_floodlights). For testing, when we force those to be .bgl - all lights appear correctly. Perhaps the add-ons need to be reinstalled or the add-ons need to be updated.

At this point we'd recommend contacting the developers of the scenery.

We will keep investigating on our end also.

Regards,
Adam
Prepar3D® Engineering Project Manager

Chok
Posts: 22
Joined: Thu Aug 25, 2016 8:15 pm

Re: Issues with night lighting after 3.4

Postby Chok » Thu Oct 27, 2016 2:19 pm

Adam Breed wrote:Chok,

After some experimentation, we believe the issue might be with one of the tools that are third party developed to switch on and off bgls. Unfortunately, we don't have much insight on how that is being triggered. You will see some scenery items with the extension changed to .off (e.g. omdb_floodlights). For testing, when we force those to be .bgl - all lights appear correctly. Perhaps the add-ons need to be reinstalled or the add-ons need to be updated.

At this point we'd recommend contacting the developers of the scenery.

We will keep investigating on our end also.

Regards,
Adam


Hello.

I'll attempt with some reinstallions and i'll go back to the other developers forums with this post and see if they can figure something out.

Note that all sceneries on my system is the latest versions, but not all of them are P3D V3.4 compatible yet.

Though i still hope the investigation on your side will bring more information regarding this issue, thanks for your help so far.

Saldo
Posts: 389
Joined: Thu Sep 18, 2014 7:26 am

Re: Issues with night lighting after 3.4

Postby Saldo » Wed Nov 02, 2016 6:00 pm

Today I found the same issue with Ajaccio from RFSceneryBuilding.
Loading the airport in the dark show Nice runway lighting.

However, coming from another airport and flying to LFKJ there is no rw lighting.
In P3D v3.2 there is no issue.

This is with the current v3.4...

If the rw lighting bgl files are loading when starting at an airport but not when flying towards the airport , what might cause this ?
I am sure that more airports are suffering from this..

What is the cause of this in v3.4 ?

Regards,

Chok
Posts: 22
Joined: Thu Aug 25, 2016 8:15 pm

Re: Issues with night lighting after 3.4

Postby Chok » Mon Nov 07, 2016 3:43 pm

Adam Breed wrote:Chok,

After some experimentation, we believe the issue might be with one of the tools that are third party developed to switch on and off bgls. Unfortunately, we don't have much insight on how that is being triggered. You will see some scenery items with the extension changed to .off (e.g. omdb_floodlights). For testing, when we force those to be .bgl - all lights appear correctly. Perhaps the add-ons need to be reinstalled or the add-ons need to be updated.

At this point we'd recommend contacting the developers of the scenery.

We will keep investigating on our end also.

Regards,
Adam


Hello again.
I did some further testing and got a small result.

If I delete my config file and let P3D build a fresh one, some of the problems appear to go away. Like for example Vienna (LOWW) appears to be fully functional with both lights and mist no matter how I try to load the airport after rebuilding the CFG.

However, it does not fix it for all airports. In Dubai the mist is still gone but the lights now spawn as they should. In Oslo everything is still missing as explained in previous posts.
I have not been able to pinpoint what setting it is in the CFG file that makes it work in Vienna but I will keep looking.


Return to “Prepar3D Client Application Questions”

Who is online

Users browsing this forum: BerndB, Bing [Bot], Majestic-12 [Bot] and 114 guests