About P3Dv5 SimConnect libraries

Chrisoft
Posts: 57
Joined: Tue Jul 31, 2012 7:29 pm

About P3Dv5 SimConnect libraries

Postby Chrisoft » Mon Apr 13, 2020 9:13 pm

Hi all,

I use Visual Studio 2015, I don't know if I can compile EXE application or DLL module for Prepar3D v5 with new SimConnect libraries.

Is it possible? Or Must I have Visual Studio 2019?

Thanks in advance! Regards,

Chris.

reinhardhussel
Posts: 1
Joined: Thu Apr 16, 2020 8:05 pm

Re: About P3Dv5 SimConnect libraries

Postby reinhardhussel » Thu Apr 16, 2020 8:06 pm

Install the .NET 4.8 SDK from Microsoft. The you can compile against that.

Chrisoft
Posts: 57
Joined: Tue Jul 31, 2012 7:29 pm

Re: About P3Dv5 SimConnect libraries

Postby Chrisoft » Sun Apr 19, 2020 9:10 am

Hello, okay thanks for your reply.

Finally, I use Visual Studio 2019.

EllipticCurve
Posts: 105
Joined: Mon Jun 12, 2017 6:14 pm

Re: About P3Dv5 SimConnect libraries

Postby EllipticCurve » Thu Apr 30, 2020 9:28 pm

I use VS2015, and was unable to build against v5 libraries.

The error message was cryptic, but it would appear that a newer VS version is required even though it doesn't appear to be the case.

Newer VS versions add nothing useful.
All comments and opinions are my own.


Return to “Software Development Kit (SDK) Questions”

Who is online

Users browsing this forum: No registered users and 19 guests