PDK: attaching an object disables property triggering

Pax_1601
Posts: 2
Joined: Sat Sep 29, 2012 8:54 am

PDK: attaching an object disables property triggering

Postby Pax_1601 » Sun Oct 13, 2019 8:19 am

Hello everyone!

I am trying to attach a simObject to an other simObject using the IBaseObject AttachObject method. The attachment works perfectly, however when I perform it, I can no longer set some properties using the TriggerProperty method.
E.g., I can set the "GENERAL ENG COMBUSTION:1" property but not the "RUDDER PEDAL POSITION" one. If the attachment is not performed, I can set all the properties with no issues. To me, it looks like some properties are freezed when AttachObject is called. If I call AttachObject at high frequency, I can set all properties, but the two objects are no longer correctly attached (the attached object "lags" behing the master object).

Am I doing something wrong? Is this a bug or known behaviour?

Thank you for your help!

Pax_1601
Posts: 2
Joined: Sat Sep 29, 2012 8:54 am

Re: PDK: attaching an object disables property triggering

Postby Pax_1601 » Sun Oct 13, 2019 3:12 pm

Some additional information.
I am developing on P3D Professional v4.5.13.32097 on a Windows 10 64bit machine.
I have also tried to attach the object using SimConnect, as well as trying to set the variables with it, with no change compared to what said before.

Thanks for your help.
Davide


Return to “Software Development Kit (SDK) Questions”

Who is online

Users browsing this forum: Majestic-12 [Bot] and 16 guests