SimConnect_MapInputEventToClientEvent issues in v3

some1
Posts: 33
Joined: Thu Sep 22, 2011 5:14 pm

SimConnect_MapInputEventToClientEvent issues in v3

Postby some1 » Mon Oct 05, 2015 3:35 pm

Hello,

It seems that this function has some issues in v3:

1. Some axes position (like RZaxis) is not returned in -32k +32k range, but 0-64k. In FSX and P3D v2 all axes return values in -32k +32k range.
2. Slider axis is not working
3. Hat return to zero is not reported. In FSX it was reported by sending -1 value.

This can easily be tested using the JoystickInput sample from Simconnect SDK.


I think I reported something similar during v2 beta, then it was changed to match FSX behavior.
viewtopic.php?f=6318&t=9245
Michal Krawczyk
A2A simulations

Lewis - A2A
Posts: 32
Joined: Tue Oct 29, 2013 7:55 pm

Re: SimConnect_MapInputEventToClientEvent issues in v3

Postby Lewis - A2A » Wed Oct 07, 2015 11:10 am

bump

Clifton Crane
Lockheed Martin
Posts: 998
Joined: Tue Sep 25, 2012 2:34 pm

Re: SimConnect_MapInputEventToClientEvent issues in v3

Postby Clifton Crane » Wed Oct 07, 2015 6:34 pm

Hello,

Could you please list the types of devices you are seeing this issue with (i.e. brand/type)?
Thanks.
Clifton Crane
Prepar3D® Software Engineer Sr.

some1
Posts: 33
Joined: Thu Sep 22, 2011 5:14 pm

Re: SimConnect_MapInputEventToClientEvent issues in v3

Postby some1 » Sun Oct 18, 2015 11:56 am

I've seen this issue with all devices I've tested (Saitek Throttle Quadrant, Thrustmaster HOTAS Warthog and Thrustmaster Cougar).
Michal Krawczyk
A2A simulations


Return to “SimConnect Interface Questions”

Who is online

Users browsing this forum: No registered users and 4 guests