Page 1 of 1

Points of Interest On Compass Issue

Posted: Thu Apr 15, 2021 7:30 pm
by Jgal
Hello,

There seems to be an issue with the compass showing the direction of the point of interest if the point of interest is attached to a world object. I have a moving carrier and points of interest are off to the side of it. When my points of interest are attached to the carrier, I can see my points of interest cycling through in the world and the name of the point updating on my compass, but the compass always has the point of interest indicator pointing back to the carrier.

When I change my points of interest to use AttachedWorldPosition instead of AttachedWorldObject, the compass points to the active point of interest as expected. Problem is I need my points of interest to move with the carrier.

Re: Points of Interest On Compass Issue

Posted: Fri Apr 16, 2021 10:15 am
by davidk64
I haven't worked with these objects but let me see if I read the question correct. Say you have a ship that is a moving object with a waypoint list and a dolphin that is a point of interest attached to the ship say 100 feet abeam on the port side. If the dolphin is attached to the ship then the dolphin moves along with the ship but doesn't get pointed to by the mission compass? But if you detach the dolphin it stays still and the mission compass will point to it? Does this mean if you want to have the dolphin pointed to by the mission compass and move you will need to create (duplicate) a separate waypoint list for the dolphin? Maybe they coded it to treat attached objects as part of the attached to object for the purposes of mission compass behaviour?

Re: Points of Interest On Compass Issue

Posted: Mon Apr 19, 2021 1:26 pm
by Jgal
Hello!

Yeah, that is what I am seeing.

I had a rectangle area by every point of interest, so I was able to get around it by having the rectangle area's AttachedWorldObject set to the carrier and the point of interest's AttachedWorldObject set to the rectangle area. Now my rectangle areas and points of interest move with the carrier and my compass points to the active point of interest/rectangle area instead of the carrier. This seems to be working if someone else runs into the same issue I did.