Page 1 of 6

P3Dv4.2 VR Single Pass Rendering Mode Issue

Posted: Wed Feb 14, 2018 1:18 am
by powayjoe
Well I installed the latest client version of P3Dv4.2 did the usual deletes of .cfg and shader files updated all the necessary add-on stuff and everything worked fine. I then tried out the VR mode with my Oculus Rift and again all looked very good but really no different then v4.1 in Native VR mode. Then I enabled the Single Pass Rendering option in the drop down and started having very strange visual artifacts as I turned my head. Things like ships showing up in the KSAN (Orbx and plain P3D versions) airport and KLGA (plain P3D version) for instance and they would come and go as I turned my head. Several other strange artifacts would also randomly appear in the distance or on runways and in flight as well. As soon as I toggle back to Stereo Rendering mode they go away and all is well.

I tried several airports with and without add-ons such as Flightbeam and Orbx as well as different countries and it made no difference. I turned on and off UTL no difference. I disabled FSUIPC no difference. I installed the latest Nvidia drivers no difference. I opened and closed Oculus Home and turned on and off ASW with the Oculus debug tool and again no difference.

I only have Orbx FTX Global Base Pack and openLC North America installed but did do the update before installing and opened it after installing to ensure it updated.

It seems the "Single pass rendering" feature that I was so excited about from a system impact perspective isn't working correctly on my system.

So has anyone else seen this behavior when they deployed the single pass rendering option?

Thanks in advance
Joe

Re: P3Dv4.2 VR Single Pass Rendering Mode Issue

Posted: Wed Feb 14, 2018 6:04 am
by gcbraun
I have the same issue. LM recommends that we use the latest NVIDIA drivers with VR, but Oculus says we should use 388.59 or earlier (which is the one I am using).

Re: P3Dv4.2 VR Single Pass Rendering Mode Issue

Posted: Wed Feb 14, 2018 8:31 am
by gcbraun
Just to confirm, I have updated to the latest 390.77 drivers and I still experience texture flashes and multiple glitches/artifacts when looking around. This happens on multiple payware scenery that I have.

Re: P3Dv4.2 VR Single Pass Rendering Mode Issue

Posted: Wed Feb 14, 2018 12:37 pm
by Kayla Kinzel
Hello,

When I go to KSAN and look left at the ships, I am seeing one ship that flickers into view once it is at the edge of my lens. Is this what you are seeing? I cannot consistently reproduce this issue, though, when switching between stereo and single pass.

Do these artifacts show up on your monitor/social screen? If so, could you post a screenshot?

Regards,
Kayla

p3dv4.2 vr single pass object flicking on/off

Posted: Wed Feb 14, 2018 1:54 pm
by kdfw
this may be related to what others are reporting:

vector object like power line towers are flickering on/of using the single pass mode. if normal stereoscopic mode is used, everything is normal.

i saw this around orbx lowi scenery.

[POST MERGED INTO TOPIC]

Re: P3Dv4.2 VR Single Pass Rendering Mode Issue

Posted: Wed Feb 14, 2018 2:30 pm
by rampa60
I'm having this same issue, artifacts everywhere (terrain and/or buildings), when in VR with SPR mode. I have the Oculus Rift visor, the last driver for my gtx 1080. Updated client and content only. At first the SPR works perfectly, but the artifact appear later in the flight.

Re: P3Dv4.2 VR Single Pass Rendering Mode Issue

Posted: Wed Feb 14, 2018 2:37 pm
by toutenglisse73
Hello. I confirm some bugs flickering with single pass VR (with default stock scenery) on airports : for exemple KSEA Seattle when looking at airport buildings I can see like big ships flickering at buildings place and when taking off and looking down to Airport I can see autogen houses flickering on airport's terrain. Maybe it's visible on screen display I'll make screenshots or video.
Also, with stock scenery, there is a flickering white or blue pixels area on the right edge of field of view. It's visible when moving head to the right and coming back to center, but only if eyes are looking forward of HMD because this pixels are on edge and if eyes are oriented to the right it's out of view (because dictance lens/eyes is short when eyes look forward and so the peripheral vision has bigger field of view .....complicated to explain for me...)

Apart from this bugs : everything else seems OK, no more disalignement problems with terrain textures or clouds, and performance are really better, the cpu room gain is important and alows max scenery complexity and dense autogen. Rendering smoothness is also very sensible.

For me the "big" issue is with photoreal textures : with single pass VR big parts of terrain just disappear, flickering, at the mid to high distance, short distance and horizon terrain being visible. This issue stops as soon as stereo mode is toggled.
With previous 4.1 stereo VR I only had this problem with a single Aircraft : the Dino Cattaneo's F-35 and it seems it was a known issue for Dino Cattaneo. But now in single pass it's a constant issue with all aircraft. Also the textures directly below Aircraft are changing, sometimes showing squares of a world map instead of terrain photoreal textures.

Everything uptodate, debug steps done, all generated folders rebuilt.

Re: P3Dv4.2 VR Single Pass Rendering Mode Issue

Posted: Wed Feb 14, 2018 3:01 pm
by powayjoe
I have a similar post over on the Avsim forum and others are seeing the same issues:
https://www.avsim.com/forums/topic/5312 ... act-issue/

I haven’t checked if it shows on the screen yet but will.
We’ve all tried several Nvidia drivers including the current ones as can be seen in the link above but no difference.

This isn’t just a minor tearing or flashing thing. At times whole objects,frequently ships will flash on top of the airport grounds or large aircraft wings or ground equipment. It almost seems close by objects are being translated out of position from somewhere else and misplaced as a brief tearing phenomenon when translating your head only in SPR mode. Both KSAN and Lagurdia airports where I see this every time are close to water and ships, interesting?

I will say I also see brief flashes in the distance as well even when flying. This doesn’t appear to be a classic tearing or flashing problem like I see when using FlyInside this actually superimposes scenery objects incorrectly in front of you as you’re taxing around airports.

Check out the other posting for more inputs please. I hope we can all figure this out because the CPU benefits are great and things look no different then Stereo Mode which is great but this frequent “tearing misplacement” thing clearly makes SPR mode unusable.

Thanks in advance for the help
Joe

Re: P3Dv4.2 VR Single Pass Rendering Mode Issue

Posted: Wed Feb 14, 2018 6:58 pm
by Kayla Kinzel
Hello all,

This seems to only be an issue with autogen buildings. If I disable autogen buildings, the issue is gone.

Could you try to disable autogen buildings to see if the issue goes away?

Regards,
Kayla

Re: P3Dv4.2 VR Single Pass Rendering Mode Issue

Posted: Wed Feb 14, 2018 7:16 pm
by powayjoe
I will when I get back to my PC.
If you are correct we still need to find the cause of that to be able to use some autogen buildings in VR I hope.
It is somehow related to the SPR proceed I assume?

Joe

Re: P3Dv4.2 VR Single Pass Rendering Mode Issue

Posted: Wed Feb 14, 2018 7:58 pm
by Kayla Kinzel
It is somehow related to the SPR proceed I assume?
Hello,

At this point in time, we don't know exactly what is the root cause of the issue, but we will continue to look into it.

Thanks,
Kayla

Re: P3Dv4.2 VR Single Pass Rendering Mode Issue

Posted: Wed Feb 14, 2018 9:11 pm
by gcbraun
Hello, I can confirm that the issue also happens for me with Autogen Buildings OFF:

Image

As said above, I get multiple texture errors, including appearing/disappearing objects.

The issue is NON-reproducible if I turn all the Scenery Objects to off (Complexity, Draw Distance, Vegetation and Buildings).

Re: P3Dv4.2 VR Single Pass Rendering Mode Issue

Posted: Wed Feb 14, 2018 10:52 pm
by toutenglisse73
Only with single pass VR :
What autogen building off solves is flickering house roofs on airports like KSEA (when moving head on some angles). But the big boats flickering are still here.
Moving waves are mostly visible with left eye (right eye there are 1 or 2 visible only).
White sprites/pixels on the right edge of right eye are visible whatever the settings.

Apart from VR modes, little issue with F-16A/C : mouse dot visible only when on an active button/pot. And colimated Hud symbols visible when looking outside of Hud's glass.

Re: P3Dv4.2 VR Single Pass Rendering Mode Issue

Posted: Thu Feb 15, 2018 12:33 am
by powayjoe
Kayla,

The SPR object appearing issue does not get resolved by turning off any of the autogen functions on my PC. Again the only solution is toggling back to Stereo Mode. Here are some photos of the bizzare objects and other complete objects that are being overlayed on the stable scenery at KSAN when I turn my headset.

Typical issue at several airports around water, this is a KSAN gate with a ships appearing
https://www.dropbox.com/s/du02437s9mt66 ... N.JPG?dl=0

Strange object appearing out the left window on KSAN Rwy 27
https://www.dropbox.com/s/j9bqllozcbgmi ... 7.JPG?dl=0

Strange shapes appearing out the canopy, perhaps the inside of the ship zoomed?
https://www.dropbox.com/s/0bck4xdkx1quc ... y.JPG?dl=0

More odd shapes
https://www.dropbox.com/s/flmhb7mqr82n1 ... y.JPG?dl=0

Push carts off KSAN Rwy 27 that shouldn't be there they just appear and disappear
https://www.dropbox.com/s/j33c9d2gtmr7l ... 7.JPG?dl=0

I hope this helps I was unable to insert the photos, sorry for my ignorance so to save time I just copied my dropbox links

Thanks I hope we can make progress
Joe

Re: P3Dv4.2 VR Single Pass Rendering Mode Issue

Posted: Thu Feb 15, 2018 12:34 pm
by Kayla Kinzel
Hello all,

These images are very different from the issue are are able to reproduce.

Have you tried uninstalling all of your addons?

Regards,
Kayla