Absolutely no scenery visible

Any issues, problems or troubleshooting topics related to computer hardware and the Prepar3D client application
Posts: 172
Joined: Thu Nov 21, 2013 11:34 pm

Postby OldAirMail » Sun Dec 01, 2013 1:06 pm

License ID: 3025369

Desktop computer is running Windows 7 64bit Professional.

16 GB ram

Radeon HD 6870 1GB 256-bit GDDR5

CPU is i5 2500K 3.3 MHz

Primary drive is an SSD DRIVE (1 GB free on SSD, 500+ GB free on secondary drive).


I started with a black screen.

I found that if I used the "-" and "+" keys I could get some color showing from inside the aircraft, but no other details at all. I was unable to get any outside view.

I've tried all of the tips to get it working, but with no luck. I did have it in windowed mode when it worked & could open another black screen by pressing "[".

There are no add-ons as I can't get Prepar3d to run.




As pirex mentioned, in another posting, I could hear the engine running, and the plane would crash into something. I soon learned to kill the engine and apply the breaks. At that point I had the time to switch aircraft. The only cockpits that I could see were what I'd call "legacy" aircraft. I couldn’t see any scenery, inside or outside.


I had FSX Acceleration installed. I never had Prepar3d V1.x installed.

All drivers were updated, and requirements meet before instillation.

Prepar3d V2 was installed as administrator. The program was run as administrator.

After being unable to see any scenery, I uninstalled my video driver, downloaded & installed 2 versions prior to the current video driver. I restarted Prepar3d V2. Same problem.

I repeated the process one version up at a time. Same problems.

I’m now worked my way up to the latest beta.

I’ve even repeated the procedure again after uninstalling Prepar3d V2 as directed in the installation pdf EACH time that I changed the video driver. After restarting the computer each time, it made no difference.


Prepar3d V2 no longer starts.

Where it once worked, after a fashion, this is what I get now, after one of those many "uninstall/install" sequences.


I’ve even re-downloaded/installed “msxml6” from MS in case the instillation I had was corrupted.

I’ve run dxdiag.




There's more on this post "It's here early 11-24-13" on SimViation.

QUESTION: Is it possible that with all of my attempts to reinstall Prepared V2 and it's related drivers that I'm locked out? I recall a dialog box saying that I the license was revoked, but when I put the correct License ID & Password in it looked like it was ok. Further re-instillations seemed to proceed normally (except, of course, that Prepar3d doesn't work).

In total, I've probably reinstalled Prepar3d 10 to 15 time trying to resolve this problem since I bought it on 11/24.

Posts: 3510
Joined: Mon Mar 04, 2013 1:02 pm
Location: Manchester, UK

Postby Saul » Sun Dec 01, 2013 2:56 pm

I would think that your graphics setting are too high for your available GPU memory.

Although your system meets the minimum requirements, it is short of being able to run it well on middle settings.

You can email Licensing@Prepar3D.com to get more activations. Just explain your situation and what you have been doing and they will understand.

What you can do once you have P3D installed again is manually edit the graphics settings if it fails to start up.

The Prepar3D.cfg that hold this information is located at C:\Users\*UserName*\AppData\Roaming\Lockheed Martin\Prepar3D v2\Prepar3D.cfg

(Where *UserName* = your windows Loggon name)



Posts: 172
Joined: Thu Nov 21, 2013 11:34 pm

Postby OldAirMail » Sun Dec 01, 2013 5:42 pm

I've just removed Prepar3d V2. Again.


From the "Technical Questions" I followed this procedure (as I have many times before).

Finally, you should reinstall Prepar3D, but first uninstall it and then manually delete the following folders:

•C:\Program Files (x86)\Lockheed Martin\Prepar3D (or the modified install location)

•C:\ProgramData\Lockheed Martin\Prepar3D

•C:\Users\*USERNAME*\AppData\Local\Lockheed Martin\Prepar3D

•C:\Users\*USERNAME*\AppData\Roaming\Lockheed Martin\Prepar3D

•C:\Users\*USERNAME*\Documents\Prepar3D Files

After those folders are removed, you can reinstall Prepar3D and everything should work as expected.


I've run CCleaner to remove junk files, and then to clean up the registry.

I’ve run “Error checking” on both drives.

I restarted the computer again, I re-ran CCleaner to be sure that there were no leftover files. I re-ran the registry cleaner. Again.


I re-installed Prepar3d V2 again (as administrator. Again) (Windows UAC has been turned off), but this time onto the secondary (E:) drive (not that that should make a difference).

I re-input my License ID & Password. It appears that it was accepted without a problem.


When I try to run the program it immediately gives me this pop-up;


No pause. No blue screen. No hesitation.


"I would think that your graphics setting are too high for your available GPU memory."

I’m aware of at least one other who is using a slower GTX 560 video card with 1GB on it that can run Prepar3d V2. And yes, he does say that it was so slow that he had to move the settings down.

When I could run the program, I did move all of the settings ALL of the way down.

All settings in the “Image and Texture Quality” were set to their lowest setting, if not completely turned off.

Every slider in “Terrain”, "Scenery Objects”, "Water and Bathymetry”, and “Special Effects” were set all of the way to the left.

All “Lighting” and “Shadows” settings were either unchecked or in the case of “Shadow Quality” moved all the way to the left.


Interestingly, when I went to "C:\Users\*UserName*\AppData\Roaming\Lockheed Martin\Prepar3D v2\Prepar3D.cfg", and opened up Prepar3D.cfg it is empty. I checked the file size and it is 0 (zero).



Obviously, something isn't right.

Equally as obvious, is that I posted this screen shot, below, on SimViation Mon Nov 25, 2013 9:48 pm.


Followed by this screen shot;


and this screen shot;


All of the way down to this one;



And now, this is what I see every time I try to startup Prepar3d;




I will admit that it is probably a setting, or file, in my computer causing the first, original, problem.

What I don't understand is why I could at least start the program, and now can't even do that little.


I have spare hard drives. I could install Windows 7 Professional (temporarily) on one of the drives, AND THEN try to install Prepar3d V2 on a clean system.

So far, I've only re-installed it on the same system.

I'm afraid that if I were to install it on a "different system" so to speak, that my license might be permanently revoked.

I've spent a week on this problem so far, if I can get permission to install it on a new drive (I want to avoid giving LM the idea that I'm attempting to double install the program) on the same computer with a new drive/OS then I'll try that.


I’ve already sent an email Licensing@Prepar3D.com. This being Sunday I don’t expect that they’ll respond.

Return to “Hardware Specific Questions”

Who is online

Users browsing this forum: No registered users and 19 guests