P3D4.3 low FPS ?fix

For all topics that don't fit into another category. Note that we cannot promise that any of these posts will be responded to by our development team.
gjmyb
Posts: 2
Joined: Sun Jan 08, 2012 3:32 am

P3D4.3 low FPS ?fix

Postby gjmyb » Fri Sep 14, 2018 6:25 am

After trying many fixes etc trying to get fps above 25 in a I7 7700K machine at 4.3 flying PMDG,s and the Citation Mustang I think I have found a possible cause and a fix. In my Prepar cfg file the VR settings were turned on and being loaded. Turning these off ( from 1 to 0 ) more than doubled my fps with very high settings. In my case this works as I do not use a VR headset. Hope that this may help.
Have fun
Gabriel Myburgh

User avatar
Beau Hollis
Lockheed Martin
Posts: 1775
Joined: Wed Oct 06, 2010 3:25 pm

Re: P3D4.3 low FPS ?fix

Postby Beau Hollis » Fri Sep 14, 2018 1:21 pm

This is the first we've heard of any FPS hit when a VR headset is not actively being used.

Do you have any VR software installed (SteamVR, Oculus Home, etc)?
When VR was enabled, did you see the "Virtual Reality" menu on the far right of the menu bar?
The VR library should do a quick check at startup to see if VR software is installed. If found, it adds some VR menu items which trigger are used to enable vr.

Thanks
Beau Hollis
Prepar3D Software Architect

gjmyb
Posts: 2
Joined: Sun Jan 08, 2012 3:32 am

Re: P3D4.3 low FPS ?fix

Postby gjmyb » Fri Sep 14, 2018 11:44 pm

Hi,
Thank you for your reply. I do not have a VR installed. I have been using FSX Boxed for many years, however, switched to P3D 4 when 64 bit started. Now 4.3. FPS no issue until v4.3. Dramatic drop in FSP PMDG 737 now at 12 to 23. In my cfg file I have 3 VR related commands. The enabled cmd is the only one with value 1. This I changed to 0 and the result was that I now have 25 to 30 FPS locked at 30 FPS .
I do not have a VR box displayed on the cmd bar. I found the many "fixes" do not really seem to change much and thought that maybe data not used is being loaded. Checking task manager all 8 cores seemed to be working at high percentages.
I do not use Jobscheduler but ? maybe should use 85 with my I7 7700?
After changing the cfg to 0 only one core is at 100 and the rest are not nearly as active as before. To me this seems that something changed. Flying fine and Orbix Nederland scenery looks exceptional.
Your opinion will be very welcome.

keino333
Posts: 11
Joined: Wed May 06, 2015 3:49 am

Re: P3D4.3 low FPS ?fix

Postby keino333 » Sun Sep 16, 2018 6:12 pm

Seemingly works...tested at Simwings Heathrow in the FSlabs A320 and it was a little smoother than usually....perhaps by 3-5 fps


Return to “Miscellaneous”

Who is online

Users browsing this forum: Majestic-12 [Bot] and 9 guests