DXGI_DEVICE_REMOVED_ERROR with Nvidia Inspector

Any issues, problems or troubleshooting topics related to the Prepar3D client application.
ironcondor
Posts: 33
Joined: Tue May 13, 2014 12:24 am

DXGI_DEVICE_REMOVED_ERROR with Nvidia Inspector

Postby ironcondor » Wed Jun 13, 2018 3:37 pm

Hello,

The saga with P3DV4.2 continues. This is a brand new machine about 4 months old. AMD ThreadRipper 1950X, 32GB of RAM, SSD, GTX-1080, not overclocked, etc. This also happened on my older machine. So it is not machine specific.

1.) I have researched and read through all of the forum posts in regards to this matter. I even removed FSUIPC AUTO SAVE referred to in one of the posts. This stopped the issue for about 1 week and then it surfaced again with no changes to the NVIDIA drivers or application add ons.

2.) This error also shows up on this machine with P3D installed with " NO ADDONS". Yes, I know you will ask if there are ADDONS installed. So I decided to try it with no addons as well. I would also like to add this only happens to P3D and no other application.

3.) DDU has been used with 5 different NVIDIA drivers. Same issue.

4.) I also purchased another video card and tried this as well. Same issue.

I followed this as well:

3) DXGI ERROR_DEVICE_HUNG \ Display driver has stopped responding and has recovered

Update or Reinstall your graphics driver, Use a driver cleaning utility like DDU, follow step (K) for additional Information

When you have completed your changes use the Delete Generated files command from step (F) and restart your computer

Then launch Prepar3D and test


5.) Other users are reporting this for you product as well in other forums?


So the question is how can I use this product any further if there is no solution? Will this be part of the bug fixes for P3DV4.3? Will we get any definitive answer on why this happens?

Thanks.
Last edited by Kayla Kinzel on Wed Jun 20, 2018 10:46 am, edited 1 time in total.

pracines
Posts: 113
Joined: Mon Nov 25, 2013 4:01 am

Re: DXGI_DEVICE_REMOVED_ERROR

Postby pracines » Wed Jun 13, 2018 7:33 pm

I'm unsure if this will help you.

In the NVidia control panel ---> manage 3D settings -Global settings tab, I changed the setting "OpenGL Rendering GPU" to my video card ( instead of Auto-select ).

This error started for me with the newest driver 398.11 and have been trying different things.

I realize P3D is not OpenGL, but saw no harm in adjusting this setting. So far with some extreme long distance/time testing I have not had the dreaded DXGI error.

I hope it helps, and I'm certain it cant hurt to try.
Win 10 64bit | Z97 Pro | i7 4790 4.6GHz | Corsair Hydro Series H80i GT Liquid Cooling |
16GB RAM | GTX 980 | Oculus Rift | 1TB Samsung EVO 850 SSD | 2TB WD Black 7200 RPM SATA 6.0Gb/s

ironcondor
Posts: 33
Joined: Tue May 13, 2014 12:24 am

Re: DXGI_DEVICE_REMOVED_ERROR

Postby ironcondor » Wed Jun 13, 2018 7:49 pm

Appreciate the post. But it does not work either. I also tried 5 different NVIDIA driver versions cleaning the old using DDU. This only happens with P3D. One more thing to note. I have noticed that it happens with AUTOSAVE of FSUIPC and or the QW787. Something is happening between the addons and P3D. Not sure if the video driver is disconnecting from P3D when a Panel Save state is happening.

pracines
Posts: 113
Joined: Mon Nov 25, 2013 4:01 am

Re: DXGI_DEVICE_REMOVED_ERROR

Postby pracines » Wed Jun 13, 2018 8:16 pm

I have never used FSUIPC AUTOSAVE, and I don't have the 787.

I personally never had this error until 398.11, its very strange.

Bu,t I intend to refresh/clean Windows 10; ever since 1803 there have been different issues with different programs. I intend to do this when P3D gets updated to 4.3 and do total clean install....its been awhile since I have done this.

I hope you get sorted quickly, take care.
Win 10 64bit | Z97 Pro | i7 4790 4.6GHz | Corsair Hydro Series H80i GT Liquid Cooling |
16GB RAM | GTX 980 | Oculus Rift | 1TB Samsung EVO 850 SSD | 2TB WD Black 7200 RPM SATA 6.0Gb/s

stiarol
Posts: 6
Joined: Sat Mar 11, 2017 8:42 am

Re: DXGI_DEVICE_REMOVED_ERROR

Postby stiarol » Wed Jun 13, 2018 8:18 pm

Also started seeing this error after updating the driver to the latest. I've tried to run DDU and install the previous driver, but are still getting the error. So something has really got messed up somewhere along the road. P3D has been rendered useless on my system for now.

hk66
Posts: 6
Joined: Mon Nov 25, 2013 7:18 pm

Re: DXGI_DEVICE_REMOVED_ERROR

Postby hk66 » Wed Jun 13, 2018 8:20 pm

I had the same issue with the two latest driver versions on my GTX1080Ti on every flight.
Reinstalled driver version 397.31 (by simply overwriting the existing driver installation) and since then my sim runs absolutely stable, even on 10-hour-flights with the PMDG777.
I will stay with this driver version for a while.
Regards
Hans

elmucki
Posts: 121
Joined: Mon May 20, 2013 9:17 pm

Re: DXGI_DEVICE_REMOVED_ERROR

Postby elmucki » Wed Jun 13, 2018 10:03 pm

this has been debated throughout a few different forums, but essentially, it has to do within code and how the driver interacts with P3D. You can always revert to a earlier driver. I use 388.71 personally as there are zero issues with it. The problem will be resolved when P3D updates their code to work with the driver.

ironcondor
Posts: 33
Joined: Tue May 13, 2014 12:24 am

Re: DXGI_DEVICE_REMOVED_ERROR

Postby ironcondor » Wed Jun 13, 2018 11:56 pm

Thanks for the posts. Yes, I have seen this debated in many places but the issue needs to be looked at by someone at LM. I have narrowed down the issue to the autosave funtion which I disabled. At that moment there are no more crashes with PMDG products. However, then any product that has an auto save panel state like the QW787 caused the error to happen again. I have tried many different NVIDIA drivers including the two mentioned above and the issue still exists.

Interestingly enough when I re-engage FSUIPC autosave it crashes with the DXGI error on PMDG products now as well. When I disable it the crash does not happen. So the question becomes why is this happening? I am not a developer so I do not know why the autosave or auto panel save state is causing this disconnect with the video driver. I do agreed LM needs to look at this issue.

Thomasba
Posts: 1
Joined: Tue May 30, 2017 10:31 pm

Re: DXGI_DEVICE_REMOVED_ERROR

Postby Thomasba » Thu Jun 14, 2018 9:38 am

I only got the DXGI_DEVICE_REMOVED_ERROR when I used nvidia inspector. as soon as I reverted back to the base profile I stopped getting the error. I use the latest Nvidia driver, ORBX, PMDG Aircraft and FSUIPC all without the error.

Martyson
Posts: 4562
Joined: Sun Mar 25, 2012 11:08 am

Re: DXGI_DEVICE_REMOVED_ERROR

Postby Martyson » Thu Jun 14, 2018 9:54 am

Thanks for the posts. Yes, I have seen this debated in many places but the issue needs to be looked at by someone at LM. I have narrowed down the issue to the autosave funtion which I disabled. At that moment there are no more crashes with PMDG products. However, then any product that has an auto save panel state like the QW787 caused the error to happen again. I have tried many different NVIDIA drivers including the two mentioned above and the issue still exists.

Interestingly enough when I re-engage FSUIPC autosave it crashes with the DXGI error on PMDG products now as well. When I disable it the crash does not happen. So the question becomes why is this happening? I am not a developer so I do not know why the autosave or auto panel save state is causing this disconnect with the video driver. I do agreed LM needs to look at this issue.
If, instead of using any developer's autosave software, you save the flight from the P3D menu, do you get the error?
Best Regards,
Vaughan Martell (KDTW)

ironcondor
Posts: 33
Joined: Tue May 13, 2014 12:24 am

Re: DXGI_DEVICE_REMOVED_ERROR

Postby ironcondor » Thu Jun 14, 2018 5:57 pm

I only got the DXGI_DEVICE_REMOVED_ERROR when I used nvidia inspector. as soon as I reverted back to the base profile I stopped getting the error. I use the latest Nvidia driver, ORBX, PMDG Aircraft and FSUIPC all without the error.

Good point. Just tested it after a DDU driver clean and new driver install. No NVidia Inspector. DXGI_Device_Removed Error on P3D again. Clean install of P3D with no FSUIPC, No Orbx, and no add ons.

Tried it on a 2nd machine and same issue.

Bummer I guess.
Last edited by ironcondor on Thu Jun 14, 2018 6:23 pm, edited 1 time in total.

Martyson
Posts: 4562
Joined: Sun Mar 25, 2012 11:08 am

Re: DXGI_DEVICE_REMOVED_ERROR

Postby Martyson » Thu Jun 14, 2018 6:12 pm

I only got the DXGI_DEVICE_REMOVED_ERROR when I used nvidia inspector. as soon as I reverted back to the base profile I stopped getting the error. I use the latest Nvidia driver, ORBX, PMDG Aircraft and FSUIPC all without the error.

Good point. Just tested it after a DDU driver clean and new driver install. DXGI_Device_Removed Error on P3D. Clean install of P3D with no FSUIPC, No Orbx, and no add ons.

Tried it on a 2nd machine and same issue.

Bummer I guess.
Just checking.
You now have two machines with the DXGI_DEVICE_REMOVED_ERROR while using the P3D Menu to Save the flight and you have verified Autosave is not in use (Autosave is not causing the error)?
Best Regards,
Vaughan Martell (KDTW)

ironcondor
Posts: 33
Joined: Tue May 13, 2014 12:24 am

Re: DXGI_DEVICE_REMOVED_ERROR

Postby ironcondor » Thu Jun 14, 2018 6:33 pm

I only got the DXGI_DEVICE_REMOVED_ERROR when I used nvidia inspector. as soon as I reverted back to the base profile I stopped getting the error. I use the latest Nvidia driver, ORBX, PMDG Aircraft and FSUIPC all without the error.

Good point. Just tested it after a DDU driver clean and new driver install. DXGI_Device_Removed Error on P3D. Clean install of P3D with no FSUIPC, No Orbx, and no add ons.

Tried it on a 2nd machine and same issue.

Bummer I guess.
Just checking.
You now have two machines with the DXGI_DEVICE_REMOVED_ERROR while using the P3D Menu to Save the flight and you have verified Autosave is not in use (Autosave is not causing the error)?

It is not related to the P3D Save the Flight function. When FSUIPC AutoSave is enabled it happens to all aircraft including default LM aircraft. Or when FSUIPC is disabled and an aircraft has some sort of Auto Panel Save funtion it happens. I have extensively tested this theory.

As I stated in my original post this seems to be with the FSUIPC Auto Save feature and/or aircraft like the QW787 doing the panel save. For example, an aircraft that does not have this type of auto save panel feature like the PMDG, ProSim737 and ProsimA320, and even the new Dash 8 Q400 there is absolutely no DXGI_Device_Remove error.


Appreciate everyone replying. I will wait for P3DV4.3 at the end of the month and hopefully this issue is resolved.

Thanks!

Martyson
Posts: 4562
Joined: Sun Mar 25, 2012 11:08 am

Re: DXGI_DEVICE_REMOVED_ERROR

Postby Martyson » Thu Jun 14, 2018 6:40 pm

"It is not related to the P3D Save the Flight function. When FSUIPC AutoSave is enabled it happens to all aircraft including default LM aircraft."

Ok.
Normal P3D Save the flight from the menu is working.

I do not use FSUIPC autosave and I never get this DXGI error.

But, I will activate FSUIPC Autosave and do a test and let you know the results.
Best Regards,
Vaughan Martell (KDTW)

Martyson
Posts: 4562
Joined: Sun Mar 25, 2012 11:08 am

Re: DXGI_DEVICE_REMOVED_ERROR

Postby Martyson » Thu Jun 14, 2018 7:01 pm

Autosaved using FSUIPC, exited P3D, rebooted PC, started P3Dv4.2, the saved flight loaded OK (no errors).

Image
Best Regards,
Vaughan Martell (KDTW)


Return to “Prepar3D Client Application Questions”

Who is online

Users browsing this forum: Majestic-12 [Bot] and 20 guests