Ground Altitude received oscillating

DevSim
Posts: 141
Joined: Thu Jul 07, 2011 12:45 pm

Postby DevSim » Wed Feb 01, 2012 9:52 am

Dear P3D-Team,



Situation:



I am taxing on a runway. The ground altitude received remains constant.



Then I taxi out into the grass, the ground altitude received oscillates heavily. Same (and this is now the strange effect) thing occurs on the grass when the position is frozen, e.g. no lat/lon change sent over SimConnect at all.



[...]

23923.689 : SimConnect::handleGroundAlt ground alt received 1415.85

23923.751 : SimConnect::handleGroundAlt ground alt received 1416.13

23924.141 : SimConnect::handleGroundAlt ground alt received 1416.14

23924.516 : SimConnect::handleGroundAlt ground alt received 1416.04

23924.578 : SimConnect::handleGroundAlt ground alt received 1415.85

23924.968 : SimConnect::handleGroundAlt ground alt received 1415.92

23925.436 : SimConnect::handleGroundAlt ground alt received 1416.05

23925.545 : SimConnect::handleGroundAlt ground alt received 1416.11

23925.608 : SimConnect::handleGroundAlt ground alt received 1416.06

[...]



How can this be explained? I expect to have the same ground altitude on the very same spot at any time.



Thanks for letting me know,



DevSim

DevSim
Posts: 141
Joined: Thu Jul 07, 2011 12:45 pm

Postby DevSim » Wed Feb 01, 2012 11:13 am

Could this be the default behaviour to simulate the grass surface? Flying over the same patch does give a steady ground altitude.



Which configuration item is responsible for this?



Thanks,

DevSim

Mike Schroeter
Lockheed Martin
Posts: 296
Joined: Thu Jan 12, 2012 7:05 pm

Postby Mike Schroeter » Wed Feb 01, 2012 12:37 pm

You are correct, the ground bumpiness is a function of world relative velocity and time. We don't bother generating bumps when you're up in the air.



I assume that since you're freezing position you are updating lat/lon/alt from your own simulation via SimConnect. I think if you also set the world velocity vector via SimConnect to reflect the updated position this should take care of it. In this scenario, a velocity of 0 should eliminate the bumps.



Hope this helps,

Mike




DevSim
Posts: 141
Joined: Thu Jul 07, 2011 12:45 pm

Postby DevSim » Wed Feb 01, 2012 12:46 pm

Mike,



Thanks for your fast reply. I don't set a velocity (yet), just position updates. I'll add a velocity and check the outcome asap.



If there is a Prepare3d.cfg method to remove the ground bumpiness anyway, please let me know.



Regards,

DevSim

DevSim
Posts: 141
Joined: Thu Jul 07, 2011 12:45 pm

Postby DevSim » Thu Feb 02, 2012 3:42 am

Thanks, works. I set "Total World Velocity" to zero and the bumpiness is gone.



Regards,

DevSim




DevSim
Posts: 141
Joined: Thu Jul 07, 2011 12:45 pm

Postby DevSim » Thu Feb 02, 2012 4:38 am

Correction:



With TOTAL WORLD VELOCITY, I get exceptions (20) but the bumpiness is gone.

Setting VELOCITY WORLD X/Y/Z, the bumbiness is back, the exceptions are gone.



What could cause the exception on TOTAL WORLD VELOCITY?



Thanks,

DevSim




Mike Schroeter
Lockheed Martin
Posts: 296
Joined: Thu Jan 12, 2012 7:05 pm

Postby Mike Schroeter » Thu Feb 02, 2012 1:19 pm

TOTAL WORLD VELOCITY is not simply set, as a vector (x,y,z) cannot be defined by a simple scalar. That's why we need to set the "..X/Y/Z" values.



Try setting the corresponding body relative values as well: VELOCITY BODY X/Y/Z.

DevSim
Posts: 141
Joined: Thu Jul 07, 2011 12:45 pm

Postby DevSim » Thu Feb 02, 2012 3:05 pm

Thanks, will try that. Do I need to set the body values all the time or just once? It's like a couple of bytes sent over the network which do nocht change at all at runtime/flying time.



Regards,

DevSim

Mike Schroeter
Lockheed Martin
Posts: 296
Joined: Thu Jan 12, 2012 7:05 pm

Postby Mike Schroeter » Thu Feb 02, 2012 5:29 pm

I suppose it depends on how in-sync you want to be with the host simulation. If you don't sync everytime your version changes you may still get the bumpiness.

DevSim
Posts: 141
Joined: Thu Jul 07, 2011 12:45 pm

Postby DevSim » Mon Feb 06, 2012 4:02 am

Thx, no bumpiness with VELOCITY BODY X/Y/Z.



Regards,

DevSim



Return to “SimConnect Interface Questions”

Who is online

Users browsing this forum: No registered users and 1 guest