Unloading Gauges Error

Any issues, problems or troubleshooting topics related to the Prepar3D client application.
RogueShadow
Posts: 1
Joined: Thu Jan 12, 2017 3:59 pm

Unloading Gauges Error

Postby RogueShadow » Thu Jan 12, 2017 4:21 pm

Hey all,

I'm new to the forum; my name is Henry and I am a Milviz gauge developer for our upcoming projects.

I just wanted to ask the community about an issue that I found and fixed. We have absolutely no explanation for this issue and it happened at a completely random time.

What is the error and how did I discover it?

In a nutshell, whenever I am testing a gauge and have written new code, I switch to a default airplane so the gauge DLL unloads (not being used by any process anymore). When unloaded, it can then be deleted and replaced. When I re-build the gauge, I have a script that deletes the old gauge in the Panels folder and copies+pastes a new gauge to the folder.

2 days ago, this error started occurring when I did my usual process of unloading the gauge and attempting to replace it with a working one:

https://dl.dropboxusercontent.com/u/577 ... ypaste.png

What this error prevented me from doing was to delete the old gauge even though it's unloaded. Something in P3D was grabbing onto the gauge DLL and not letting go. The only way to delete it was to completely shut down P3D.

I fixed it in my explanation below but I have zero idea why it's caused and thought I might ask the community.

Two days ago, it just randomly started happening.

Solution (but it doesn't make sense):

I fixed it by renaming my P3D root folder. It was D:\Prepar3D, but I renamed it to D:\Prepar3DRenamed and it started working again. I was able to delete the gauge replace it with a new one to test - just like how it worked 2 nights ago.

Although it's now fixed, it still doesn't make any sense; there must be something that looked for my gauge DLL in D:\Prepar3D. Now that I renamed the folder to D:\Prepar3DRenamed, it could not locate my gauge DLL and the gauge is now able to be unloaded and deleted after I switch to a default aircraft.

To the community:

I thought I'd share the solution I found to this issue. However I am still curious:

Does anyone know what might be the cause of the problem? None of us here have ever heard of or have had this issue - seeing that it happened so randomly.

2 nights ago, my colleague and I did an extensive debugging of the gauge but there was nothing in the code that could of told Prepar3D to explicitly grab onto the DLL until it shut down. Also, seeing how I fixed it by renaming the P3D folder, the same gauge that was being grabbed on was suddenly released and unloaded.

Cheers,

Henry Chen

Return to “Prepar3D Client Application Questions”

Who is online

Users browsing this forum: Bing [Bot], Google [Bot], Majestic-12 [Bot] and 14 guests