P3D ATC doesn't recognize "Num1"

Any issues, problems or troubleshooting topics related to the additional features present in the Prepar3D Professional Plus client application.
Posts: 21
Joined: Wed Apr 08, 2015 2:13 am

P3D ATC doesn't recognize "Num1"

Postby ncngrr » Fri May 31, 2019 9:40 pm

On P3Dv4.5 (without the Hotfix).

I installed a small number keypad on my instrument panel so that I could simply push a number button to select an option from the default P3D ATC menu (announce taxi, position, on final, etc.)

Was disappointed when P3D ATC didn't recognize those button pushes. Used the number keypad on my keyboard, same thing. Used the number across the top of the keyboard, it worked correctly.

Went to registered version of FSUIPC and saw that when I press the numbers across the top of the keyboard, FSUIPC registered the press as a "1", "2", ....

When I pressed the numbers on the keypad (either on the keyboard or the separate keypad), FSUIPC registered the press as a "Num1", "Num2", etc...

I confirmed NumLock is turned on... on both keypads. Tried it turned off as well, just because.

What must I do to get P3D to respond appropriately to the keypad entries? I'm trying to remove the keyboard altogether from my cockpit... it's been an elusive goal!


Return to “Prepar3D Professional Plus Client Application Questions”

Who is online

Users browsing this forum: No registered users and 8 guests