Sim Director - lines missing in .XML file

Any issues, problems or troubleshooting topics related to the additional features present in the Prepar3D Professional Plus client application.
whitav8
Posts: 201
Joined: Sat Nov 06, 2010 6:14 am

Sim Director - lines missing in .XML file

Postby whitav8 » Fri Sep 22, 2017 4:28 pm

Rob (and others),
I am trying to develop a SImDirector Scenario file that has a combination of aircraft and ground vehicles following waypoint lists and I can't get that to work well just yet. I started to examine the XML file that is generated by SimDirector in order to compare it with some of the Missions I used to use and I noticed that some of the Aircraft State information seems to be missing from the XML file. Items that should be there for AircraftAIState like "SIMPLE_FLIGHT", Assigned Airspeed, and other info. Would you please check into that - obviously things could be different now than before SimDirector and V2-3 but I added the following:
<AircraftAIState>SIMPLE_FLIGHT</AircraftAIState>

to one of my aircraft and it flew differently.


Dave W.

P.S. As far as setting up a waypoint list for aircraft, it would seem that with SimDirector, all I need to do is connect the aircraft and the waypoint list with a simple WaypointListReference?

whitav8
Posts: 201
Joined: Sat Nov 06, 2010 6:14 am

Re: Sim Director - lines missing in .XML file

Postby whitav8 » Thu Sep 28, 2017 8:47 pm

Rob,
Perhaps you are busy with P3Dv4.1 but I would appreciate a response to the missing XML lines question when you get a chance.

Dave

User avatar
Rob McCarthy
Lockheed Martin
Posts: 1882
Joined: Wed Aug 24, 2011 1:37 pm

Re: Sim Director - lines missing in .XML file

Postby Rob McCarthy » Fri Sep 29, 2017 12:51 pm

Hi Dave,

Are you seeing any validation errors when saving your scenario? Also are you seeing this issue with all vehicles?
You are correct with the basic steps for setting up waypoint AI. You may need to adjust the waypoint touch distance if vehicles are having a tough time navigating to the waypoint, especially at higher speeds.

Regards,
Rob McCarthy
Rob McCarthy
Prepar3D® Core Lead

whitav8
Posts: 201
Joined: Sat Nov 06, 2010 6:14 am

Re: Sim Director - lines missing in .XML file

Postby whitav8 » Fri Sep 29, 2017 1:53 pm

Rob,
I am not seeing any validation errors. Here is a OneDrive link to my scenario at Grand Canyon West (looks great with BlueSky photoreal scenery - http://www.blueskyscenery.com/AZ_North5West3.html )

https://1drv.ms/u/s!Ah-GN1pAHAEHiRYf2I0yTISUQobO


Again, the issue is that some of the AI Aircraft State information seems to be missing from the XML file

Note: I will adjust my touch distances to be a lot bigger - the Tank just seems to drive in small circles.

Thanks for taking the time to look at this (I didn't send the ownship (F-16) fxml/wx in the above files)

Dave W.

whitav8
Posts: 201
Joined: Sat Nov 06, 2010 6:14 am

Re: Sim Director - lines missing in .XML file

Postby whitav8 » Fri Oct 13, 2017 3:21 pm

@L-M, Rob,
Any chance you have had a moment to take a look at my scenario and see if you agree that some AI State commands are missing in the XML file?

Thanks

Dave

User avatar
Rob McCarthy
Lockheed Martin
Posts: 1882
Joined: Wed Aug 24, 2011 1:37 pm

Re: Sim Director - lines missing in .XML file

Postby Rob McCarthy » Mon Oct 30, 2017 6:23 pm

Hi Dave,

There appears to be missing references in the WingmanFormation AI properties. Does setting these to the desired vehicle fix the issue you are seeing?

Regards,
Rob McCarthy
Rob McCarthy
Prepar3D® Core Lead

whitav8
Posts: 201
Joined: Sat Nov 06, 2010 6:14 am

Re: Sim Director - lines missing in .XML file

Postby whitav8 » Tue Oct 31, 2017 2:10 am

@Rob,
Thanks for getting back with me. I'm not sure what you mean by " Does setting these to the desired vehicle fix the issue you are seeing?" Perhaps you are saying that if I edit the XML file and manually add AI STATE data that the formation works better - I actually don't think that formation attribute is really working that well no matter what. Certainly there should be all AI State settings data in the XML file UNLESS there is a default set of values that don't need to be mentioned in the XML file. If that is true, then I would like to know just what are the default settings. My tank just spins around and never follows the waypoints - BTW, just how do I set the touch distance (I can't find it with SimDirector). The AI Aircraft do fly a general oval shaped path but they never come close to my waypoints (maybe they need to be much further away from each other?). If you could please try my XML file that I provided above, you would certainly be able to see what might be going on.

Thanks

Dave

User avatar
Rob McCarthy
Lockheed Martin
Posts: 1882
Joined: Wed Aug 24, 2011 1:37 pm

Re: Sim Director - lines missing in .XML file

Postby Rob McCarthy » Tue Oct 31, 2017 2:49 pm

Hi Dave,

I don't recommend manually editing the xml file. Just like with actions the wingman behavior has an object reference that must be set to the commanding entity. This link has not been set in your scenario therefore the AI has not entity to follow. The waypoint touch distance can be set for aircraft. This is at the bottom of the aircraft AI properties. If an AI misses a waypoint it will try to reroute to this point before proceeding to the next one. This is most likely what is causing the behavior you are seeing. Also giving enough distance from the initial waypoint and correcting the orientation so vehicles are facing the first waypoint will help as well.

Regards,
Rob McCarthy
Rob McCarthy
Prepar3D® Core Lead

whitav8
Posts: 201
Joined: Sat Nov 06, 2010 6:14 am

Re: Sim Director - lines missing in .XML file

Postby whitav8 » Wed Nov 01, 2017 12:11 am

@Rob,
As far as WIngman Formation for the two F22s, you are correct - the version that I sent you was after I just hooked the two F22s to the same waypoint list since I had tried to hook one of them to the waypoint list and then just connect the other with the wingman formation list to the F22 that had a waypoint list and it didn't work at all.
So should I be able to connect one aircraft to a waypoint list and then connect another aircraft to that first aircraft via the wingman formation? Then, if I start them near each other (lat,lon,alt,heading) the wingman should follow the other "loosely"?

I have a tank trying to follow a 3 waypoint list with wrap=true at 6knots, 2 knots turn speed, and 6.5 second turn time with Body Relative Offset and Rotation = true. Should that work - the tank just spins in heading never going anywhere.

I am still asking whether there is AI State information about the AI aircraft that should be in the XML - Aircraft AIState like "SIMPLE_FLIGHT", Assigned Airspeed, and other info.


Thanks

Dave

User avatar
Rob McCarthy
Lockheed Martin
Posts: 1882
Joined: Wed Aug 24, 2011 1:37 pm

Re: Sim Director - lines missing in .XML file

Postby Rob McCarthy » Wed Nov 01, 2017 12:41 pm

Dave,

The waypoint list for the tank is attached to the tank which is causing the rotation you are seeing. When the tank moves the waypoint list is moving relative to the tank as well. You will need to remove the attached world object from this list and set it to a static location in the world to prevent this from happening.

If a waypoint list is set for an AI it does not use the other behaviors and just follows the waypoints. If you want the AI to use simple flight or another general AI type then you will need to removed the waypoint list reference.

F-22s can be difficult to set up using the wingman formation and waypoints due to their high speeds. You may need to further tweak parameters including the MaxBank angle or use a different aircraft in this case.

Regards,
Rob McCarthy
Rob McCarthy
Prepar3D® Core Lead

whitav8
Posts: 201
Joined: Sat Nov 06, 2010 6:14 am

Re: Sim Director - lines missing in .XML file

Postby whitav8 » Wed Nov 01, 2017 9:44 pm

@Rob,
OK - that fixed the tank! Too bad the wingman won't work with the F22 - I'm flying them at @250 knots so it shouldn't be a real problem. Therefore, I am just setting them both up exactly the same and connecting to the same waypoint list - kind of works - loose formation.

BTW, I still get the CTD if I try to go from the actual sim over to SimDirector using the Tools Tab.

Thanks for your support

Dave W.
Last edited by Rob McCarthy on Thu Nov 02, 2017 11:02 am, edited 1 time in total.
Reason: Advertising scenery in reply

User avatar
Rob McCarthy
Lockheed Martin
Posts: 1882
Joined: Wed Aug 24, 2011 1:37 pm

Re: Sim Director - lines missing in .XML file

Postby Rob McCarthy » Thu Nov 02, 2017 11:11 am

Hi Dave,

Glad to hear that worked. When you get a chance can you re-upload the crash dump? I am no longer able to access it.

Regards,
Rob McCarthy
Rob McCarthy
Prepar3D® Core Lead

whitav8
Posts: 201
Joined: Sat Nov 06, 2010 6:14 am

Re: Sim Director - lines missing in .XML file

Postby whitav8 » Thu Nov 02, 2017 4:07 pm

@Rob,
I will send you a link next week to a crash dump - I'm out of town.

Thanks much for your help!

Dave W.


Return to “Prepar3D Professional Plus Client Application Questions”

Who is online

Users browsing this forum: No registered users and 2 guests