Page 1 of 1

I have the weirdest fps issue I have ever witness with P3D V5

Posted: Mon Jun 22, 2020 9:03 pm
by fogboundturtle
This weekend I bought Aerosoft A320 Professional 64 bit version for P3D V5. After my install, My P3D was never the same.

First my pc specs : AMD Threadripper 1950x, RTX 2080Ti, 32GB Ram @ 2933mhz. Windows 10 1904 build.

Before we start, My P3D was working fine all weekend. I have no issue with maintaining acceptable FPS. After my install of Aersoft. The problem begins. I have extreme low fps everywhere. When I started the Aerosoft A320, I had 7fps. When I changed the FPS limited from 90 to unlimited I gain 3 more fps. So that's 10 fps.

I started to do my own troubleshooting. After a completed wipe of Prepar3D, Removing all ORBX products or any other 3rd party addons. I did a fresh install of P3D HF1. So I started the game with the default airport and default scenery. So I am as vanilla as it gets.

I change the 30 fps limiter to unlimited. When I am in the cockpit of the jet plane. I get 25fps. If I pause the sim I jump to 125 fps. If I switch to any outside view, I get 10fps. If I pause the sim, 185 fps. I have no idea what is causing this. I suspect it might be the latest vc redist x64 version that might be at cause. I have tried to uninstall this version and use the one that came with P3D but I also had the same result.

I am flabbergasted by this problem. I am unable to figure this out. Can anyone have any idea ?

Re: I have the weirdest fps issue I have ever witness with P3D V5

Posted: Mon Jun 22, 2020 9:49 pm
by fogboundturtle
I finally found a resolution. I had to uncheck Dynamic 3D autogen vegetation and everything when back to normal. Now I am able to turn it back on again and have zero issue.