Page 1 of 1

2080ti SLI Stutters with Shadows

Posted: Sun Jan 26, 2020 8:19 pm
by MistyBlue
I currently have 2x EVGA 2080ti's in SLI (NVLink) across 3 2k screens using NVSurround with Fly-Elise warping (PC specs in sig below). I'm using this is a home cockpit with Prosim so this is just the external view (no virtual cockpit).

Performance now seems to be good (with Surround versus View Groups), being able to hold a pretty smooth 60 FPS at FlightBeam KSFO with AIG traffic at 30% and no shadows. However, when I enable shadows, I get significant stuttering. I also see odd shadow flickering, even at the highest level, something I don't recall seeing with a single card.

Are there known issues with SLI and shadows? I can live without them, but sure would be nice to get it working smoothly with shadows enabled.

Re: 2080ti SLI Stutters with Shadows

Posted: Mon Jan 27, 2020 7:52 am
by JorgenSA
Tony, just as an experiment - what happens to the stutters if you limit the frame rate to 25 or 30, for instance?

Jorgen

Re: 2080ti SLI Stutters with Shadows

Posted: Mon Jan 27, 2020 4:27 pm
by MistyBlue
Hey Jorgen,

Thanks for the suggestion. The stutters do disappear at 30 FPS. I see more of a screen shutter effect now, though, in terms of smoothness whereas at unlimited the frames were much more fluid with shadows turned off.

What are your thoughts as to why the stutters are happening?

BTW, the stutters happen with or without SLI so it appears to not be an SLI issue. I do still have the shadow flickering, though, even at ultra res.

Re: 2080ti SLI Stutters with Shadows

Posted: Tue Jan 28, 2020 8:13 am
by JorgenSA
The way I understand it, and this is only how I personally view the various explanations I have seen, is that by limiting the frame rate like this, you give the processor more time to "build the whole frame" and then present it, instead of the processor striving to build as many frames as possible with a resulting lack of completeness in every frame.

Interestingly, I have no stutters - with shadows turned on - on my own system, which is an i7-7700K @ 4.66 GHz, 16 GB of 2133 MHz DDR4 RAM and a GTX 960, frame rate limited to 25. Your system should be so much more powerful than mine, so I wonder why this is.

As for SLI, I have no experience with that myself. But I do remember another current thread where SLI was discussed as having just about no effect at all. Why that is, is a very good question - is it P3D's handling of SLI, the Windows handling of SLI, or nVidia's own handling of SLI, or a combination of any or all of the above?

Jorgen

Re: 2080ti SLI Stutters with Shadows

Posted: Tue Jan 28, 2020 1:09 pm
by MistyBlue
Thanks Jorgen. I'll experiment with some sort of frame limiting and see if I can smooth things out with shadows.

I have a separate decently high-end desktop test system I use (8800K, 1080TI, etc) that I don't have shadows trouble with, but it's a single monitor not using NV Surround so therein may lie the problem.

Wondering if anyone else using Surround is experiencing similar issues with shadows.