Page 1 of 1

Out of Memory on startup Error

Posted: Sun Feb 02, 2020 6:06 pm
by jetpilot1980
So I too had this issue yesterday and was a bit surprised. In my case it happened as I was initially loading Prepar3D and I had the CTD before I even reached the initial scenario menu. For me the surprise comes from the fact that while I realize I may not have the latest most powerful system out there; my system is far from anemic either. I have 32GB ram; 8GB GPU; and 2 x 4TB HDD so I would think my computer has plenty of available real-estate to run programs with. After doing some research and trying a couple of things I finally am back to smooth running (no I did not change P3D in any way) I have seen solutions such as messing with DLL.xml and Prepar3d.cfg and did not want to go that route. Seeing that this appears to be a somewhat common and annoying issue I thought I would share the solution I found:

1. Restart the computer and try again (the obvious step but sometimes that's enough)


2. Check the virtual memory settings:

1. In the Windows search bar (I am running Win 10 Pro) type in "advanced system settings" and click on "view advanced system settings (control panel) when that pops up.

2. Once the menu pops up click on the advanced tab and under the advanced tab click the Performance Settings button

3. Once inside the Performance Options menu again click the advanced tab and under the advanced tab click the change button

4. Under the virtual memory menu un-click the automatically manage box at the top; then adjust the hard drive settings as desired. In my case I set my E: drive to automatically mange (previously my C: was on auto and my E: was off) and left my C: on auto; then click the Set button and the ok button; the computer will prompt you to restart again.

Since I cannot insert images into this post here is a link to a youtube video that demonstrates how to perform this procedure (I recommend skipping to the 4m 32s mark) https://youtu.be/-oHZM7rSyGY


3. I installed a small program called Empty Standby List that clears my memory cache every 5 min now. The program can be found here https://wj32.org/wp/software/empty-standby-list/ as well as a youtube video on how to install it / create a windows task to run it: https://youtu.be/A5bclGbY1ik

After having accomplished those tasks I am back to smooth running again! Hope this post can save some other people out there some frustration...

Re: Out of Memory on startup Error

Posted: Sun Feb 02, 2020 7:30 pm
by JorgenSA
Which version of P3D is this?

I run v. 4.5, have virtual memory turned off with 16 GB of RAM and have never had an OOM error in P3D.

Jorgen

Re: Out of Memory on startup Error

Posted: Sun Feb 02, 2020 9:14 pm
by jetpilot1980
I am running 4.5 HF2...