Major FPS drop/CTD when changing views (V4.3)

Any issues, problems or troubleshooting topics related to the Prepar3D client application.
Loadhaul
Posts: 1
Joined: Sun Aug 05, 2018 10:09 am

Major FPS drop/CTD when changing views (V4.3)

Postby Loadhaul » Sun Aug 05, 2018 10:38 am

Hi.
Sometimes when I change views from internal to external cameras using the default method my FPS drops significantly to about 4FPS and is not recoverable, further more the result is a CTD with an error.
The issue seems to be very inconsistent, as it seems to be very random sometimes happening and sometimes doesn't happen at all. There seems to be no said spot for this to happen, that's the issue it can strike any time during my flight which as a result causes a CTD. The CPU usage does indeed go to 100% abnormally when the issue is present, and would stay in normal ranges when it isn't. It seems to occur only after I've updated to V4.3, something to note; Chaseplane is in use. Here is the error message indicated:

"The device (NVIDIA GeForce GTX 970) stopped working for
the following reason: DXGI_ERROR_DEVICE_HUNG. Do you
want to exit Prepar3D? Click yes to exit, no to disable
rendering to this device, or cancel to keep using this device
(Prepar3D may crash)."

-Deleted Prepar3d.cfg to rebuild it.
-Deleted Shaders folder.
-Reinstalled V4.3 with Content, Scenery and Client.
-Deactivated ORBX products.
-Try'd multiple aircraft and airports.
-Updated NVIDIA Drivers.
-Occurs without Chaseplane in use.

My system:
GeForce GTX 970
I7-4790K CPU @ 4.00GHz
16GB Ram
2560x1440, 59Hz
Windows 7

Could this issue correlate to a P3D issue, or could this be an issue with the actual GTX 970 or PC itself? The fact it seems to black out the screen with 4fps and then cause a CTD with this error and is very inconsistent could mean it's a P3D issue. I'm unable to see what else I could try to fix this issue, if anyone else is having it as well please let me know.
Thanks!

Aeronaut711
Posts: 5
Joined: Tue Oct 06, 2015 7:43 pm

Re: Major FPS drop/CTD when changing views (V4.3)

Postby Aeronaut711 » Tue Aug 07, 2018 8:26 pm

Same issue here. CPU Core 0 is at 100% and the GPU load drops down to very low load during the issue. No CTD up to now observed during this issue. Sometimes i can recover normal FPS by opening and close the save screen or pressing esc key and resume several times. I have updated from 4.1 to 4.3. by following the recommendations for updating P3d published on this forum. Orbx is running and active sky.
my system:
CPU i7 5960x,
Geforce 980ti,
RAM 32 GB
2560x1440
Windows 10 pro

shivers9
Posts: 9
Joined: Mon Sep 19, 2011 5:59 pm

Re: Major FPS drop/CTD when changing views (V4.3)

Postby shivers9 » Tue Aug 07, 2018 10:18 pm

Please add me to this list. I too am having these problems. All that I can add to the post of other reference this problem is that I think that this is a case of the sim losing focus and get somehow stuck while trying to recover. I have P3d in the task bar and when it happens I noticed that the icon blinks yellow as though the sim has been paused. I hope you are making progress in sorting this out.

I7 3770K
980TI
16 GB Ram
4K Monitor
Windows 10 Home

User avatar
Brady Butler
Lockheed Martin
Posts: 603
Joined: Tue May 09, 2017 5:31 pm

Re: Major FPS drop/CTD when changing views (V4.3)

Postby Brady Butler » Wed Aug 08, 2018 12:27 am

Hello,

To have us assist you further, could you please review this topic and let us know the results from following the troubleshooting steps?

http://www.prepar3d.com/forum/viewtopic ... 2&t=123246

If the issue is determined to be caused by an add-on, you will likely want to reach out to the add-on developer for direct support. If they need any support with development, they should not hesitate to contact us.

Regards,
Brady
Brady Butler
Prepar3D® Software Engineer

ryanbatc
Posts: 10
Joined: Thu May 22, 2014 2:52 am

Re: Major FPS drop/CTD when changing views (V4.3)

Postby ryanbatc » Wed Aug 08, 2018 1:15 pm

I'm glad I'm not alone. Been having this issue very often, since 4.2

wwhite993
Posts: 4
Joined: Sun Aug 12, 2018 10:56 am

Re: Major FPS drop/CTD when changing views (V4.3)

Postby wwhite993 » Sun Aug 12, 2018 11:02 am

I have been having a similar issue, though my problem seems to be related to sound.

When I start P3D, everything is smooth. Sound is turned on. However, when I switch to the external view, the FPS drops significantly below 5 frames. If I press 'Q' to turn the sound off, the frames revert back to normal (in external view). If I press 'Q' again to turn the sound back on, the frames drop back to 5. My problem is also non-recoverable, unless I use my monitor's headphone jack as the audio output.

I rolled back to the previous Nvidia driver just to be sure it isn't a video problem, and even reinstalled my audio drivers. So far, no luck.

User avatar
Raphael_Chacon
Posts: 68
Joined: Tue Apr 07, 2015 5:40 pm

Re: Major FPS drop/CTD when changing views (V4.3)

Postby Raphael_Chacon » Wed Aug 15, 2018 3:05 am

+1

There is no long haul that i overcome the CTD..... i though it was because of overclocking(i reseted to default), then because the aircraft(changed from PMDG 747, to 777, to QW787, to FSW LJ35A, Tfdi B712) Its the same..... If i want to perform a long flight, well, i got to take the CTD pill...... It will eventually happen.... So i went back in the history and discovered that it is happening after 4.3 update......


Some of the errors:

Image
(This one today, after 15 hours flight gone to the wate can again...)

Image

Image


The last one, weather.dll....i though it was solved by deleting WX files inside P3DV4 files folder, but as long as the sim(FSUIPC autosaves, or any i dont care who's software) starts to save Wx files into the document/P3DV4 Files folder, i get the CTD, sometimes during flight, and 99% sure when closing the sim(it goes CTD)...... So it is not solved really. Ive talked to HiFi(which lead to the temporary solution), FSUIPC guys(which state its not their software) so nobody is...... this is Perfect!

Ucrtbase.dll i dont know whats is going on..... several hundred of times same error....changing any king of aircrafts you can imagine, any kind of flights, different flight time....... I always get same error, mostly during long flights(sit and wait for it), as well as Kernell thing.... Happened with TFDi, even opened a thread about it, but guess what... its not them neither....jaja

OMG this 4.3 version has got several --- several---several headaches packed in....... i dont care where its all of this comming from, its something around hitting everyone and needs some attention....

...

...
Image
INV-2071056

User avatar
Raphael_Chacon
Posts: 68
Joined: Tue Apr 07, 2015 5:40 pm

Re: Major FPS drop/CTD when changing views (V4.3)

Postby Raphael_Chacon » Sat Aug 18, 2018 11:36 pm

Though it'll be interesting for DEVs to review some scenery problems with this in common: Installed V4.3

1) Report of elevation issues at OTHH after installing full V4.3 and buying scenery. Other users confirm no problem with payware OTHH but running V4.1. A final user reports he updated to 4.3 but client only and OTHH looks good, no elevation issues. So, users with V4.3 have elevation issues(scenery like issues). Anothe thing, im not sure where i read it but there is a problem with OTBD / OTHH, are they even in V4.3 as default? i think Doha was removed... may be there is something...

2) Crashing when selecting sceneries. In my case, KEYW. You can check my post in the link. I dont have a solution yet. Before creating a flight from KEYW, I have to enter to another airport, and being inside the sim, then select and change position to KEYW to avoid inmediate CTD, no other way around for me at the moment.

Happy Flying...
Image
INV-2071056


Return to “Prepar3D Client Application Questions”

Who is online

Users browsing this forum: Google [Bot] and 23 guests