[RESOLVED] Screen blinks black every 10-15 seconds Prepar3D v4.2

Any issues, problems or troubleshooting topics related to the Prepar3D client application.
bhorv67
Posts: 154
Joined: Mon Dec 28, 2015 9:17 pm

[RESOLVED] Screen blinks black every 10-15 seconds Prepar3D v4.2

Postby bhorv67 » Tue Mar 20, 2018 12:43 am

This has been a really hard problem to track down, as it happens randomly and I may not experience the issue in the next 20 flights.
What happens is once I've taken off, the main screen of the sim will blink black for a split second, every few seconds. The blink happens once, but not a regular intervals. Meaning, it's not a constant blink every 5 seconds. It will do it once, then again a few or more seconds later.

All my components are new, so I don't believe the GPU could be the issue (Strix GTX 1080ti - latest driver)

I keep 2 graphic profiles that I switch between in the sim, depending on time of day. The only difference between those profiles is turning Dyn Ltg on/off, and cloud & terrain shadows on/off.

Has anyone else noticed this or come by a fix?
Thanks in advance
Win 10 1903/ Asus Prime Z370A/i7 8700k/Corsair H100i v2 Cooler/32G GSkill Trident Z DDR4 3200/Corsair TX750 / Strix GTX 1080ti/AOC 4k Display/500g WD NVMe m.2 (Win)/ 500g Samsung 970 EVO Plus NVMe m.2 (p3d 4.5) / Logitech Z5500 / Corsair K70 & Glave

Martyson
Posts: 6039
Joined: Sun Mar 25, 2012 11:08 am

Re: Main Screen blinks black every 10-15 seconds

Postby Martyson » Tue Mar 20, 2018 1:17 am

Which P3D / version are you using?
Best Regards,
Vaughan Martell (KDTW)

bhorv67
Posts: 154
Joined: Mon Dec 28, 2015 9:17 pm

Re: Main Screen blinks black every 10-15 seconds

Postby bhorv67 » Tue Mar 20, 2018 1:25 am

4.2
Win 10 1903/ Asus Prime Z370A/i7 8700k/Corsair H100i v2 Cooler/32G GSkill Trident Z DDR4 3200/Corsair TX750 / Strix GTX 1080ti/AOC 4k Display/500g WD NVMe m.2 (Win)/ 500g Samsung 970 EVO Plus NVMe m.2 (p3d 4.5) / Logitech Z5500 / Corsair K70 & Glave

Martyson
Posts: 6039
Joined: Sun Mar 25, 2012 11:08 am

Re: Main Screen blinks black every 10-15 seconds

Postby Martyson » Tue Mar 20, 2018 1:45 am

Ok,
P3Dv4.20

How old is you PC?

"All my components are new,"

Did you build your PC?
Best Regards,
Vaughan Martell (KDTW)

bhorv67
Posts: 154
Joined: Mon Dec 28, 2015 9:17 pm

Re: Main Screen blinks black every 10-15 seconds

Postby bhorv67 » Tue Mar 20, 2018 1:50 am

New build, per my profile below, built within the last 4 months. All components are new.
Win 10 1903/ Asus Prime Z370A/i7 8700k/Corsair H100i v2 Cooler/32G GSkill Trident Z DDR4 3200/Corsair TX750 / Strix GTX 1080ti/AOC 4k Display/500g WD NVMe m.2 (Win)/ 500g Samsung 970 EVO Plus NVMe m.2 (p3d 4.5) / Logitech Z5500 / Corsair K70 & Glave

Martyson
Posts: 6039
Joined: Sun Mar 25, 2012 11:08 am

Re: Main Screen blinks black every 10-15 seconds

Postby Martyson » Tue Mar 20, 2018 1:51 am

New build, per my profile below, built within the last 4 months. All components are new.
Did you build it yourself?
Best Regards,
Vaughan Martell (KDTW)

bhorv67
Posts: 154
Joined: Mon Dec 28, 2015 9:17 pm

Re: Main Screen blinks black every 10-15 seconds

Postby bhorv67 » Tue Mar 20, 2018 1:53 am

I did - have done a few builds, so to qualify, this was not my first.

Don't have issues in any other application as far as I can tell.
Win 10 1903/ Asus Prime Z370A/i7 8700k/Corsair H100i v2 Cooler/32G GSkill Trident Z DDR4 3200/Corsair TX750 / Strix GTX 1080ti/AOC 4k Display/500g WD NVMe m.2 (Win)/ 500g Samsung 970 EVO Plus NVMe m.2 (p3d 4.5) / Logitech Z5500 / Corsair K70 & Glave

Martyson
Posts: 6039
Joined: Sun Mar 25, 2012 11:08 am

Re: Main Screen blinks black every 10-15 seconds

Postby Martyson » Tue Mar 20, 2018 1:56 am

I did - have done a few builds, so to qualify, this was not my first.

Don't have issues in any other application as far as I can tell.
I think you have a hardware problem (failure) with your home built PC.

Are you still using any of your other builds?
Best Regards,
Vaughan Martell (KDTW)

bhorv67
Posts: 154
Joined: Mon Dec 28, 2015 9:17 pm

Re: Main Screen blinks black every 10-15 seconds

Postby bhorv67 » Tue Mar 20, 2018 2:11 am

The older builds were gutted. This is what I use for work & sim.

What do you think may be a hardware issue?
Nothing has shown up on any benchmark or hardware tests
Win 10 1903/ Asus Prime Z370A/i7 8700k/Corsair H100i v2 Cooler/32G GSkill Trident Z DDR4 3200/Corsair TX750 / Strix GTX 1080ti/AOC 4k Display/500g WD NVMe m.2 (Win)/ 500g Samsung 970 EVO Plus NVMe m.2 (p3d 4.5) / Logitech Z5500 / Corsair K70 & Glave

Martyson
Posts: 6039
Joined: Sun Mar 25, 2012 11:08 am

Re: Main Screen blinks black every 10-15 seconds

Postby Martyson » Tue Mar 20, 2018 2:21 am

The older builds were gutted. This is what I use for work & sim.

What do you think may be a hardware issue?
Nothing has shown up on any benchmark or hardware tests
Your parts are probably still under warranty .. that would be a plus.

My thought ... contact your PC parts supplier to log the problem (under warranty / service request) and see what they suggest.
Best Regards,
Vaughan Martell (KDTW)

bhorv67
Posts: 154
Joined: Mon Dec 28, 2015 9:17 pm

Re: Main Screen blinks black every 10-15 seconds

Postby bhorv67 » Tue Mar 20, 2018 2:43 am

This problem doesn't exist in any other circumstance. No other applications are giving me issues. I think it is unlikely a hardware issue is causing this. I would agree with you only if the issue persisted during other programs, which it is not.
Win 10 1903/ Asus Prime Z370A/i7 8700k/Corsair H100i v2 Cooler/32G GSkill Trident Z DDR4 3200/Corsair TX750 / Strix GTX 1080ti/AOC 4k Display/500g WD NVMe m.2 (Win)/ 500g Samsung 970 EVO Plus NVMe m.2 (p3d 4.5) / Logitech Z5500 / Corsair K70 & Glave

Jay Dunn
Posts: 17
Joined: Fri Oct 21, 2016 5:54 am

Re: Main Screen blinks black every 10-15 seconds

Postby Jay Dunn » Thu May 31, 2018 5:14 am

I have the same ‘blinking screen issue’ on two different P3d v4 (4.1.7.22841) one is using a projector the other is a video monitors. Only P3d is having this issue, no other programs blinks. I thought it may be the Oculus Rift, I shutdown and disconnect all the Oculus USB and HDMI connections, but the problem still happens. It even happens with P3d spared onto tow screens, both screens blink simultaneously. This just started a few days ago around May 28, 2018. Perhaps some update has caused this. Anyone found a solution?

Jay Dunn
Posts: 17
Joined: Fri Oct 21, 2016 5:54 am

Re: Main Screen blinks black every 10-15 seconds

Postby Jay Dunn » Thu May 31, 2018 7:01 am

Changed the Target Frame Rate (setting) from Unlimited to 60 the blinking went away, changed it back to Unlimited – the blinking did Not come back. More testing needed.

umelec
Posts: 20
Joined: Sun Jul 22, 2012 3:05 pm

Re: Main Screen blinks black every 10-15 seconds

Postby umelec » Thu May 31, 2018 7:25 am

I have the same problem here, but with a viewgroup setup. One system monitor with the docked P3D_V4.2 program on it, three monitors (TVs) in a viewgroup, undocked. On ground everything is ok. Once in the air, suddenly the system monitor starts with irregular blackouts. I tried then several new view selections, with and without full screen, no help. The viewgroup itself is stable. Setting fps from unlimited to 60 reduces the blackouts, but they don't disappear.
Urs Meyer

umelec
Posts: 20
Joined: Sun Jul 22, 2012 3:05 pm

Re: Main Screen blinks black every 10-15 seconds

Postby umelec » Thu May 31, 2018 8:41 am

Just one more info: When I switch off the viewgroup, the system monitor gets stable immediately. So I think it cannot be an overheat or similar of the graphics card (GTX980ti). And it is very clear: with a 60fps limit the blackouts are reduced significantly. By the way, I have the impression that this occurs only since the last Windows10 update, but I cannot confirm this for sure.
Urs Meyer


Return to “Prepar3D Client Application Questions”

Who is online

Users browsing this forum: Google [Bot] and 32 guests