Page 1 of 1

PBR Materials Fail to Load/Render in 3dsMax (v4.5 SDK)

Posted: Thu Apr 11, 2019 10:52 am
by DavideP3D
HI,
i just updated the SDK to the new 4.5 version but i can't show the material in the viewport!
If i use the standard i have no errors.
Also when i open the old pbr project(4.4 sdk) i get an Dirext x shader problem of albedo texture.
I can't press the button, it's locked.
It's just 3DS max, if i export the model all looks good!

help pls.

Re: P3D 4.5 SDK NOT SHOWING MATERIAL IN VIEWPORT!

Posted: Thu Apr 11, 2019 4:00 pm
by Rob McCarthy
Hello,

Thanks for the report. We'll look into this in more detail and get back to you.

Regards,
Rob McCarthy

Re: PBR Materials Fail to Load/Render in 3dsMax (v4.5 SDK)

Posted: Thu Apr 11, 2019 8:43 pm
by Clifton Crane
Hi DavideP3D,

The issue is that the PBR shader's file path was saved out with the scene. With the update to v4.5 the SDK path has been changed as well as the shader's location. As a work around you can add "External File" directories to 3dsMax which should allow the shaders to be found:

1. In 3dsMax, open the following menu: Customize > Configure User Paths
2. In the External Files tab, click Add
3. Add the path to the PBR shader for the currently installed SDK (see example below)

Example SDK Shader Directory:
%%%PROGRAMFILES%%%\Lockheed Martin\Prepar3D v4 SDK 4.5.x.xxxxx\Modeling\3ds Max\bin\MaxHLSL

The next time the scene is loaded, the correct shader should be found.

Hope this helps.

Re: PBR Materials Fail to Load/Render in 3dsMax (v4.5 SDK)

Posted: Fri Apr 12, 2019 11:45 am
by DavideP3D
Thank you! It works.