Page 1 of 2

Posted: Fri Apr 15, 2011 12:14 am
by jpearson
it would be nice if, in addition to being able to receive the usual notifications when things are beginning to load, i.e. flight files, aircraft files, etc., SimConnect clients could also receive notifications when these things are finished loading as well. Often times I would like to do some additional processing after a certain flight file or aircraft has loaded but im forced to guess how long loading might take and run a wait timer or sleep a thread of whatever before i bother trying to proceed with anymore processing...of course, these loading times are variable from system to system, so its never a satisfactory solution.



of course if someone knows a better way to do what im doing, then by all means...enlighten me :)

Posted: Sat Jan 21, 2012 4:55 am
by SimXLive
I have a way, not great but it works. Use the event you are tracking in combination with Sim Paused and Sim Stopped System Events. Set booleans for all three, when they come un-paused and un-stopped and your event was set the event has completed.

Posted: Wed Feb 01, 2012 9:47 am
by DevSim
I strongly support jpearsons wish.



Sim Stopped/ Sim Start are not reliable _at all_ at least in V1.2. The sim start event is received before the loading bar is gone.




Posted: Fri Feb 03, 2012 8:35 am
by WBard
Hey All,



thanks for catching this. we do have this one fixed for the next release. the SimStart and Stop will be back to normal.

Posted: Fri Feb 03, 2012 10:27 am
by DevSim
Awesome. Might I ask if the height of terrain returned will be also correct once the sim start event is received in the upcoming version?



That would even be more awesomer, to say.



Thanks,

DevSim

Posted: Fri Feb 10, 2012 2:37 pm
by cliff
Hi What version will this be fixed in? I am using the 1.2.0.0 version of simconnect, actually can you add a date/time stamp to the downloads page to show when the files where last changed.



Also will the issue of multiple simStart/simStop events on reload of the scenery be fixed?



Thanks



Cliff.

Posted: Thu Mar 22, 2012 10:42 am
by DevSim
Bump.

Posted: Fri Mar 23, 2012 4:23 pm
by FSMP
Is there a RELEASE DATE yet for the next version of P3D ( Current version at this time being 1.2.0.0) ??

Posted: Sat Mar 24, 2012 11:00 am
by Adam Breed
Hello,



As I am sure you are aware, version 1.3 was released yesterday afternoon. For more information on the SimStart/SimStop changes, please see the 1.3 release notes: http://www.prepar3d.com/prepar3d-version-1-3-release-notes-change-log/

Posted: Sun Mar 25, 2012 4:50 am
by DevSim
Thanks for the fix - looking forward to seeing it in action soon :)



Regards,

DevSim

Posted: Tue Apr 03, 2012 11:06 am
by DevSim
Adam,



Could you please look into this again? Using Version 1.3:

I still get the SimStart Event before the loading bar on the screen is gone on the initial load.

I sometimes also still get another SimStop/SimStart event again after the first loading, looks like we're not there quite yet.

At least, the returned altitude looks to be valid on the reception of the first SimStart Event now.



Short one, first value is a timestamp

[...]

93.347 : SimConnectProtocol::handleGroundAlt - sim stop event received

94.345 : SimConnectProtocol::handleGroundAlt - sim start event received

[...]



Regards,

Devsim

Posted: Wed Apr 04, 2012 4:36 am
by DevSim
Some more feedback, I don't know if someone from LM is still tracking this bug. But there's for sure an issue still around. This time it's again regarding the ground altitude received. Allthough the SimStart Event has been received after a far reposition, the ground altitude is still the old one and changes only a few seconds (sometimes one, sometimes multiple seconds) later to the correct one.



Please investigate.



4218.329 : SimConnectProtocol::handleGroundAlt - sim start event received

4218.329 : SimConnect::handleGroundAlt ground alt after sim start received 434

4218.360 : SimConnect::handleGroundAlt ground alt received 434



4218.657 : SimConnect::handleGroundAlt ground alt received 434

4218.719 : SimConnect::handleGroundAlt ground alt received 434

4218.781 : SimConnect::handleGroundAlt ground alt received 434

4218.844 : SimConnect::handleGroundAlt ground alt received 434

4218.906 : SimConnect::handleGroundAlt ground alt received 434

4218.969 : SimConnect::handleGroundAlt ground alt received 434

4219.047 : SimConnect::handleGroundAlt ground alt received 434

4219.109 : SimConnect::handleGroundAlt ground alt received 434

4219.171 : SimConnect::handleGroundAlt ground alt received 434

//--> then here we go with the correct one, 1 second late

4219.234 : SimConnect::handleGroundAlt ground alt received 90.9974

4219.296 : SimConnect::handleGroundAlt ground alt received 90.9974



Thank you for your feedback,



DevSim

Posted: Wed Apr 04, 2012 8:59 am
by Adam Breed
Hi DevSim,



We are looking into the issues. We will provide updates when we make any progress.



Thanks for your assistance,

Adam

Posted: Wed Apr 04, 2012 9:46 am
by DevSim
Thanks Adam, very much appreciated.



DevSim

Posted: Tue Apr 17, 2012 10:38 am
by DevSim
This is creating me headaches - any updates on when this can be confirmed as a bug and fixed for version 1.x/2.x?



Thanks!



DevSim