Set Weather raduis is sooooo small

redouane_bpw
Posts: 31
Joined: Sat Dec 01, 2018 1:29 pm

Set Weather raduis is sooooo small

Postby redouane_bpw » Sat Feb 09, 2019 12:43 am

hello i'm making a weather engine
when i set a metar
if i select set mode global : i got many changes like wind speed , QNH, cloud state , .... almost everything
if i select set mode custom : i got what i need :D : but nooo cus the raduis is so small
if we are approaching an airport we need to get so close to get the vars we want
and sometimes like me with KSFO : i was approaching normally with engine Enabled and i get a clear great sky with some clouds, and when i get about 20 sec from the touch, boom weather changed totaly, winds,rain QNH everything even visibility
so i checked mybe it was a weather update but no
i put the slew mode and kept going to and away from the airport and found that set weather on observation has a small raduis :'(

any help plz
simconnect with C#

thnx in advance

Pete Dowson
Posts: 573
Joined: Sat Dec 18, 2010 3:45 pm

Re: Set Weather raduis is sooooo small

Postby Pete Dowson » Sun Feb 10, 2019 9:08 am

i put the slew mode and kept going to and away from the airport and found that set weather on observation has a small raduis :'(

I don't think it is, but each Weather Station will have its own weather set. Your setting should actually gradually blend into the weather station's weather as you move between, but this doesn't always happen well, especially in areas with lots of close weather stations.

Bear in mind that weather is only recorded and controlled from weather stations (those listed in WXstationlist.bin). This is why programs like ActiveSky which set weather from trans-oceanic flights have to do so by making temporary weather stations in the the ocean -- there are SimConnect facilities for this (aee SimConnect_WeatherCreateStation)..

The airport you were approaching would have a weather station co-located. Not all the airports do, but most, and certainly all the larger ones. You will need to set your weather there too.

Pete
My System

Win10: 1803 build 17134
Processor: I9 9900K at 5.5GHz
Mobo: Maximus XI Formula Z390
Memory: 32Gb at 3600 MHz.
GPUs: 2 x 2080Ti SLI
Displays: 3 x 1080p projectors at 30Hz onto 210 FOV curved screen
P3D4 set with 3 windows in surround mode


Return to “SimConnect Interface Questions”

Who is online

Users browsing this forum: No registered users and 5 guests