[RESOLVED] SimConnect not working?

mcdonar
Posts: 102
Joined: Sat Nov 23, 2013 2:20 pm
Location: Winchester, UK
Contact:

[RESOLVED] SimConnect not working?

Postby mcdonar » Wed Dec 27, 2017 10:54 am

I cannot get my PMDG 777 to connect to P3Dv4.1.

When I start P3D and load the default fighter aircraft, everything appears normal. However, when I load my 777 I only get a blank P3D screen. The Windows Task Manager shows that P3D is occupying the usual amount of memory, but the CPU usage is 0%. The only way out is to end the task with the Task Manager.

I have run 'Reset this PC' in Windows 10 and reinstalled P3D and the PMDG 777, but to no effect. Reinstalling Active Sky shows that it too cannot connect to the simulator.

My support ticket with PMDG has ended with them identifying SimConnect as failing, and suggest they can do no more but advise I contact LM.

I have now exhausted my options in identifying the problem area. I have also followed Poppet's checklists at
http://www.prepar3d.com/forum/viewtopic ... 2&t=126570 without any success.

How can you help?
Regards, Richard
https://www.youtube.com/channel/UCwLN7SF50xpMHqVvOAmiOwA
Win10, P3Dv5.0, PMDG 748 & 777, ASP5 + ASCA, vPilot, PFPX

ZKIWI
Posts: 21
Joined: Tue Mar 26, 2013 5:29 am

Re: SimConnect not working?

Postby ZKIWI » Wed Dec 27, 2017 6:44 pm

Can you copy and paste the contents of your SimConnect.xml file in to a message to start trouble shooting? I had the same issue and it turned out the SimConnect.xml was slightly incorrect.

Are you running the sim and addons on the same computer or over a network?

mcdonar
Posts: 102
Joined: Sat Nov 23, 2013 2:20 pm
Location: Winchester, UK
Contact:

Re: SimConnect not working?

Postby mcdonar » Wed Dec 27, 2017 7:08 pm

Hi!
I am running on a single PC and therefore believe that I do not require a SimConnect.xml file. I have been told that it is only required for a server.
If this is not true, perhaps you could send a copy of your file to me at speedbird747@ntlworld.com.
Many thanks, Richard
Regards, Richard
https://www.youtube.com/channel/UCwLN7SF50xpMHqVvOAmiOwA
Win10, P3Dv5.0, PMDG 748 & 777, ASP5 + ASCA, vPilot, PFPX

User avatar
aeronauta
Posts: 1531
Joined: Sun Oct 23, 2011 1:56 am
Location: Melbourne, Australia

Re: SimConnect not working?

Postby aeronauta » Wed Dec 27, 2017 8:24 pm

try installing simconnect ... go to H:\Prepar3d V4\redist\Interface\FSX-SP2-XPACK\retail\lib and run SimConnect.msi , then restart your PC , see if it works , the add on may need a different simconnect version..
You are correct simconnect.xml is only required for remote access.
Jorge
Jorge Roldan
OZx Developer (aero) - Hovercontrol Helicopter Certified Pilot - Spad.Next Beta Tester - VATPAC Pilot PR - Nemetz Designs Beta Tester

ZKIWI
Posts: 21
Joined: Tue Mar 26, 2013 5:29 am

Re: SimConnect not working?

Postby ZKIWI » Thu Dec 28, 2017 1:55 am

Hi!
I am running on a single PC and therefore believe that I do not require a SimConnect.xml file. I have been told that it is only required for a server.
If this is not true, perhaps you could send a copy of your file to me at speedbird747@ntlworld.com.
Many thanks, Richard
In that case no need for a SimConnect.Xml file.

PMDG777 does still need SimConnect locally to run so ensure you have the correct version(s) loaded. You can load and run more than one. PMDG has several topics on how to do this on their knowledge base.

https://support.precisionmanuals.com/kb ... hID=164434

mcdonar
Posts: 102
Joined: Sat Nov 23, 2013 2:20 pm
Location: Winchester, UK
Contact:

Re: SimConnect not working?

Postby mcdonar » Fri Dec 29, 2017 8:17 am

Hi Jorge and Zkiwi,
Many thanks for your responses.
Instead of just running the three .msi files as Administrator, I decided to uninstall each first. The reinstall then gave an Accept/Decline option which I had not seen previously. This fixed it!
So now I am on the road to recovery.
Again many thanks,
Cheers, Richard
Regards, Richard
https://www.youtube.com/channel/UCwLN7SF50xpMHqVvOAmiOwA
Win10, P3Dv5.0, PMDG 748 & 777, ASP5 + ASCA, vPilot, PFPX


Return to “SimConnect Interface Questions”

Who is online

Users browsing this forum: No registered users and 23 guests