Taxiways disappeared on custom airports

Discussion related to terrain/scenery design.
scruffyduck
Posts: 134
Joined: Sun Mar 06, 2011 11:24 am

Postby scruffyduck » Sat Nov 30, 2013 10:52 am



Quote:

Quote from Pop on November 30, 2013, 08:44

Max, yes they (taxi ways) are missing in 2.0 but all work fine in 1.4?




OK then you can use the latest version of ADE if you wish to fix any missing Draw flags in one go. The fix function will set all the flags to the stock values without any need to edit XML.


jdhaenens
Posts: 7
Joined: Sat Sep 18, 2010 11:58 pm

Postby jdhaenens » Tue Dec 03, 2013 4:54 pm

I have only installed KNFL in Version 2.0 and I found (as above) that the taxiways are missing, but I designed them with AFX rather than ADE. I can also confirm missing buildings (lots of them) at KNFL. It looks like the photoreal stuff is there, but I haven't been out to where I did some landclass changes yet to see if they made the transfer. I don't know where to start...why the buildings are gone...what's up? I did the building placement with Instant Scenery 1.x, but if a group shows (as they do along the missing apron) why are others not showing?



Best to you Jon. Thanks



Jim Dhaenens

jdhaenens
Posts: 7
Joined: Sat Sep 18, 2010 11:58 pm

Postby jdhaenens » Wed Dec 04, 2013 5:20 pm

Never mind. I am in the middle of digging out from a two headed hard drive crash (They'll never BOTH fail at once, right?). I had installed an earlier (development)version of KNFL rather than the final version. The only thing that didn't come through that I could see was the light wash from the taxi light effect. KNTU was my first FSX airport and had LOTS of FS9 stuff going on along with a few SCASM tidbits. Someone was re-doing it on MAIW so I never went back to FSX-ize it. Not even sure if I have the .mdl's anymore.



Jim

Pop
Posts: 324
Joined: Sun Jul 29, 2012 8:20 pm

Postby Pop » Wed Dec 04, 2013 10:19 pm

KNTU is our (VCVW8)'s home base and we use it a lot. Each has a parking spot assigned, etc. I have now installed P3D 2.0 4 times. Before any "addon scenery" KNTU is ok. I instal your scenery and, again all works well. Parking spots,buildings and nav aids. Save a flight with a "stock" T6 in a spot. Again all works fine. Now I install another add on scenery(not another kntu) and BOOM! The taxi ways go away( but yellow lines and blue taxi way lights are OK) and parking spots are no longer available, as well as some buildings????(nav aids still work). Hope this might help!

Uninstall and reinstall all OK again????


Pop
Posts: 324
Joined: Sun Jul 29, 2012 8:20 pm

Postby Pop » Thu Dec 05, 2013 8:17 am

On my 5th reinstall I may have come up with the cause of some of MY problems. I had both P3D 1.4 and 2.0 installed on the same drive. I uninstalled 1.4 and it "appears" the taxi way and parking spot problem is gone?????

scruffyduck
Posts: 134
Joined: Sun Mar 06, 2011 11:24 am

Postby scruffyduck » Thu Dec 05, 2013 10:59 am



Quote:

Quote from Pop on November 30, 2013, 08:44

Max, yes they (taxi ways) are missing in 2.0 but all work fine in 1.4?




We know this - I thought you wanted to know how to fix the issue


FransKes
Posts: 4
Joined: Sat Apr 07, 2012 7:12 pm

Postby FransKes » Wed Jan 01, 2014 4:01 pm

Unfortunately, (at least for me) the DrawSurface flag does not seem to get fixed after re-compiling a .bgl airport file (replacing KORD in Chicago) with ADE 1.60; the taxiway surfaces are still not drawn. Taxiing at KORD still causes the aircraft to suffer irreparable damage. ScruffyDuck, you mentioned the possibility of editing the .xml file manually, but I see no method in ADE for creating a .xml file from a .bgl file.



Happy New Year,



Frans Kes



P.S. I found and used ScruffyDuck's Bgl2Xml utility to decompile the .bgl file to a .xml file. I then updated the xml file (changed drawSurface="FALSE" to drawSurface="TRUE") for KORD using Notepad++, and then I used ADE to recompile the .xml file to a .bgl file. The taxiways now show up as expected. Wonderful tools. 2014 is already looking promising.



FCK

User avatar
Peter Dooley
Posts: 102
Joined: Wed Mar 07, 2012 6:52 am

Postby Peter Dooley » Wed Jan 15, 2014 2:33 am

I have just re-compiled an airport with the no-draw taxiway problem that I had previously created for V1.4 using ADE 1.6. To solve the problem, go to the Lists tab, select Taxi Links and check "Reset all draw flags" button located below. This will automatically change all the the Draw FALSE tags to TRUE and your taxiways will be visible.

scruffyduck
Posts: 134
Joined: Sun Mar 06, 2011 11:24 am

Postby scruffyduck » Sun Jan 19, 2014 2:18 am



Quote:

P.S. I found and used ScruffyDuck's Bgl2Xml utility to decompile the .bgl file to a .xml file. I then updated the xml file (changed drawSurface="FALSE" to drawSurface="TRUE") for KORD using Notepad++, and then I used ADE to recompile the .xml file to a .bgl file. The taxiways now show up as expected. Wonderful tools. 2014 is already looking promising.




As already mentioned. The current version of ADE has a function to reset taxi link draw flags to their proper values.


Return to “Scenery Development Questions”

Who is online

Users browsing this forum: No registered users and 17 guests