Taxiways disappeared on custom airports

Discussion related to terrain/scenery design.
minime
Posts: 1198
Joined: Mon Jun 10, 2013 4:33 pm

Postby minime » Wed Nov 27, 2013 6:19 am



I changed some airports with ADE that work fine in v1.4.



Now in v2.0 all the taxiways disappeared. The aprons are still there. Objects are missing as well, for example lamps.



Do we know why this is happening and is there a fix?



Thx!

Pop
Posts: 324
Joined: Sun Jul 29, 2012 8:20 pm

Postby Pop » Wed Nov 27, 2013 9:17 am

In my KNTU scenery (Jim D's)all the parking spots are gone from the drop down list. ( see the same at KNSE)?? have not tried others.

User avatar
Max Perry
Lockheed Martin
Posts: 425
Joined: Tue Sep 14, 2010 1:22 am

Postby Max Perry » Wed Nov 27, 2013 12:08 pm

for the taxiways, can you look at the airport .xml and see if drawSurface="False" for the <TaxiwayPath .. entries? Turning it to true would make them visible. Taxiway types used to not be able to be invisible, and type="PATH" was the only option.



For lamps, and parking spots I could use some more information. The lamps, do you have a screenshot of them in 1.4? Pop, the parking spots are missing from the UI list at go to airport?

Ian P
Posts: 11
Joined: Thu Dec 15, 2011 12:00 pm

Postby Ian P » Wed Nov 27, 2013 3:39 pm

All the sceneries I have created are showing only the runways and aprons in v2. All the parking spots are present in the drop-down lists, but none of the taxiways show up.



They were created in ADE9x and it does, indeed, look like the "drawSurface" is FALSE on all TaxiwayPath entries. That's almost certainly why they're not appearing and is presumably the default setting used by ADE... We'll have to set Jon on that one, possibly, as ADE doesn't have the option to change that within the package, it looks like you can only change the entries by editing the XML manually.



Cheers,



Ian P.

scruffyduck
Posts: 134
Joined: Sun Mar 06, 2011 11:24 am

Postby scruffyduck » Thu Nov 28, 2013 3:01 am

As already mentioned ADE created airports have these flags defaulted to FASLSE. This is because they are not used in any earlier versions and were ignored by ADE. This will be fixed in the upcoming release of Version 1.60. 1.60 will support P3D v2 directly and will deal with the flags problem. It will mean that any old ADE airports used in P3D v2 will need to be recompiled to ensure that the flags are set correctly. ADE 1.60 also has a major new feature that allows users to use custom ground polys and lines. Initial indications are that these will work in v2 I hope that 1.60 will be released to production next week.

scruffyduck
Posts: 134
Joined: Sun Mar 06, 2011 11:24 am

Postby scruffyduck » Thu Nov 28, 2013 4:27 am

Would someone from LM please clarify that it is the DrawSurface flag that is now honoured in v2? Can you confirm that the DrawDetail flag is still ignored?



Thanks


scruffyduck
Posts: 134
Joined: Sun Mar 06, 2011 11:24 am

Postby scruffyduck » Thu Nov 28, 2013 8:43 am

OK I have now sorted out how these flags are set for the different types of taxiway at stock airports. ADE 1.60 will handle these correctly and pass them to the compiler. The user can change the flags as desired and this information should be passed into V2. Recompling FSX/P3D v1 ADE airports will set the flags correctly to the defaults.



Out of interest the defaults appear to be:



Taxi, Runway, Closed and Vehicle links have both flags set

Parking has the Surface flag unset and the Detail flag set

Apron/Path has both flags unset.


Ian P
Posts: 11
Joined: Thu Dec 15, 2011 12:00 pm

Postby Ian P » Thu Nov 28, 2013 4:48 pm

Thanks Jon.



That'll save me a lot of find/replace work in the XML!



All the best



Ian P.

scruffyduck
Posts: 134
Joined: Sun Mar 06, 2011 11:24 am

Postby scruffyduck » Fri Nov 29, 2013 2:45 am

I am packaging the new version now. Hopefully it will be available by the weekend


Pop
Posts: 324
Joined: Sun Jul 29, 2012 8:20 pm

Postby Pop » Fri Nov 29, 2013 10:20 am

Well things have changed, but.. When I reinstalled 2.0 and the KNTU scenery(Author: Jim Dhaenens (jdhaenens@sbcglobal.net), Build 1.2 for FSX, Oceana Naval Air Station Virginia Beach, VA), I had no parking spots in the drop down. I closed 2.0, opened 1.4 to check what I had there. Had the spots. Went back to 2.0 and the Parking spots were there???? and remain. But there seems to be some other scenery issuers. The buildings/taxiways are different. Seen in 1.4, not in 2.0( will add pic later)

Pop
Posts: 324
Joined: Sun Jul 29, 2012 8:20 pm

Postby Pop » Fri Nov 29, 2013 10:27 am

links to pic's (hope this works) http://s282.photobucket.com/user/starron4/media/13.jpg.html?filters[user]=72606658&filters[recent]=1&sort=1&o=0

http://s282.photobucket.com/user/starron4/media/1.jpg.html?filters[user]=72606658&filters[recent]=1&sort=1&o=1


660923Kb
Posts: 21
Joined: Mon Jun 04, 2012 9:17 am

Postby 660923Kb » Fri Nov 29, 2013 11:00 am

Is the xml file in the bgl file and if so how do I mannually edit it? With ADE?

scruffyduck
Posts: 134
Joined: Sun Mar 06, 2011 11:24 am

Postby scruffyduck » Fri Nov 29, 2013 12:14 pm



Quote:

Quote from 660923Kb on November 29, 2013, 11:00

Is the xml file in the bgl file and if so how do I mannually edit it? With ADE?




I am not sure I understand this question - what XML file? XML is never in a Bgl file - it is usually the source. Also if you refer to the taxiway problem then there is no need to manually edit anything if you install the latest version of ADE (1.60) which is referred to in another post here


scruffyduck
Posts: 134
Joined: Sun Mar 06, 2011 11:24 am

Postby scruffyduck » Sat Nov 30, 2013 8:40 am

It has been reported to me that some Bgl files made (I think) with AFX show FALSE for the Apron DrawSurface flag and therefore these aprons don't show up in P3D v2. I am adding a function to reset flags for aprons as well - should be available over the next day or so.

Pop
Posts: 324
Joined: Sun Jul 29, 2012 8:20 pm

Postby Pop » Sat Nov 30, 2013 8:44 am

Max, yes they (taxi ways) are missing in 2.0 but all work fine in 1.4?


Return to “Scenery Development Questions”

Who is online

Users browsing this forum: No registered users and 18 guests